[Glade-users] Menu Editing Issue

On Tue, 2003-04-15 at 23:17, Rikke D. Giles wrote:
It's probably a Glade 2 bug that is triggered by something in the
Bluecurve theme.

If anyone can get a decent stack trace, then please attach it to the
at http://bugzilla.gnome.org/show_bug.cgi?id=105694

I'm going to get RedHat 9.0 to see if I can reproduce it there.


Definitely bluecurve.  I tried my method of duping the bug without 
using bluecurve, and couldn't get it to trigger. But as soon as I 
switched to bluecurve, glade2 locked.  I'll try and get a stack trace.

With RedHat 9.0 I can finally reproduce it, with Glade 1.1.3.

Glade 2.0.0 does seem to have fixed it, fortunately.
(Although the reporter of the above bug isn't convinced yet.)

If anyone else sees the problem with Glade 2.0.0, let me know, and get a
stack trace if possible.

(The problem was that some themes, especially bluecurve, define some
additional icons, but they don't seem to be in the default icon factory.
The Glade code wasn't checking for NULL icon sets being returned, so it
caused various problems.)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]