[Glade-users] Glade segfault when selecting

greg kurzawa b bayer com wrote:


I'm experiencing a confusing problem with Glade, and I wonder if anyone else has
come across it.
Glade 0.5.11 has worked beautifully for me for about 4 weeks.  Suddenly, no
matter on an old project or a newly created one, I get segfaults when selecting
certain widgets in order to view their properties, such as buttons, and clist
labels.  Core dumps the moment I select the widget.  I am able to create a text
box, but in doing so I receive this error:

Gtk-WARNING **: gtk_scrolled_window_add(): cannot add non scrollable widget use
gtk_scrolled_window_add_with_viewport() instead

This is normal. Ignore this warning.
If I try to enter anything into the text box, I get a segfault and a core dump
the moment I touch a key.

I am using:
OS: Linux (RedHat 6.2, kernel 2.2.12-20)

I have tried recompiling glade to no avail.
This one's got me stumped.
I can supply core dumps if they would help.

Stack traces would be handy.

Have you changed your theme recently? I vaguely remember a problem with
certain themes that may cause SEGVs. Though it was never confirmed.

Have you upgraded anything else on your system recently? (kernel, libc, GTK+?)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]