[Glade-users] locale problem? -- cat-id-tbl.c error

New to glade, I was just trying out a trivial project to see
how it works. Just following the 'turbo-start' page,
everything seems to work. The first  time i ran autogen.sh,
I got messages saying I needed to fix (apparently) some
locale ENV variables to satisfy perl. I set those (perl now
works), and moved on to the next problem: 

bash-2.04$ ./autogen.sh
**Warning**: I am going to run `configure' with no
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

processing .
deletefiles is 
Creating ./aclocal.m4 ...
Running gettextize...  Ignore non-fatal messages.
Shall I run config.status? (y/N)
You should update your own `aclocal.m4' by adding the
macro packages gettext.m4, lcmessage.m4 and progtest.m4 from
the directory `/aclocal'
Making ./aclocal.m4 writable ...
Running aclocal  -I macros ...
aclocal: macros/gettext.m4: 11: duplicated macro
aclocal: macros/gettext.m4: 199: duplicated macro
aclocal: macros/lcmessage.m4: 11: duplicated macro
aclocal: macros/progtest.m4: 13: duplicated macro

It says non-fatal messages, so I take it at its word, and
figure I'll get to them later. I then run make and get:

gcc -c -DLOCALEDIR=\"/usr/local/share/locale\"
-DHAVE_CONFIG_H -I.. -I. -I../intl -I../lib
-I/usr/X11R6/include/gtk12 -I/usr/local/include/glib12
-I/usr/local/include -I/usr/X11R6/include -g -O2 -Wall
-Wunused -Wmissing-prototypes -Wmissing-declarations 
rm -f libintl.a
ar cru libintl.a intl-compat.o bindtextdom.o dcgettext.o
dgettext.o gettext.o  finddomain.o loadmsgcat.o
localealias.o textdomain.o l10nflist.o  explodename.o
ranlib libintl.a
Making all in po
make: don't know how to make cat-id-tbl.c. Stop
*** Error code 1

Stop in /usr/home/brownicm/Projects/project2.
*** Error code 1

Stop in /usr/home/brownicm/Projects/project2.

What's up here? I'm not unfamiliar with compiling code and
not unfamiliar with C, but no expert, admittedly. I assume
that I need to have cat-id-tbl.c in some library or source
directory, but I don't. It doesn't exist on my machine. I'm
running gcc-2.95.2 on FreeBSD 4.1. Is it supposed to be part
of gtk or something else? I'm in over my head, no doubt, but
I love to get my hands dirty. I would appreciate any
pointers. Thanks...

Chris Browning
brownicm prokyon com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]