Re: [Gimp-developer] gimp: GEGL-WARNING: ..[] EEEEeEeek! 1 GeglBuffers leaked

Julien Michielsen schreef op 07-05-2020 17:25:
I recently installed Ubuntu 20.4, which comes with 2.10.18.
I tried to edit a screenshot of a typescript I had made (a
png file).  I had made a rectangular selection of a part of
the screenshot, and when I wanted to save this selection of
the typescript I got the message:
runtime check failed:
(g_queue_is_empty (&cache_queue))
EEEEeEeek! 1 GeglBuffers leaked

The error I experienced (and can reproduce as often as I
wish) looks like the one experienced by Elle Stone
"GeglBuffer leaks when using GIMP to cut a selection
Submitted by Elle Stone @ellestone

Link to original bug (#770241)"

It looks to me like if there is an error in gimp when making
rectangular selections and saving these to disk, and I report
this in the hope it helps to solve this.

Today the same error happened again to me.  I had done the following,
like previous time: opened a png-file with gimp (a snapshot of my screen,
showing a graph I had found with firefox), made a rectangular selection
of the graph, pasted the rectangular graph in a file I just created in
gimp (file, new, giving a size just big enough to copy the graph into),
subsequently I exported the file with the graph to a new png-file). Up
till this moment everything went fine. Only my departure from Gimp is
accompanied with the EEEeEEek! message. The last one I got:
gimp: GEGL-WARNING: (../gegl/buffer/gegl-tile-handler-cache.c:1076):gegl_tile_cache_destroy: runtime check failed: (g_queue_is_empty (&cache_queue))

So the problem seems to be linked to the departure and closure of
gimp. I hope this can be usefull for diagnosing the problem.

Julien Michielsen

Julien Michielsen
julien michkloo xs4all nl

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]