Re: [Gimp-developer] configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >= 0.7.7


On Sat, Jul 14, 2018 at 3:40 AM, Liam R E Quin <liam holoweb net> wrote:

On Wed, 2018-07-11 at 14:59 +0100, richard brown via gimp-developer-
list wrote:
"configure: Eeeeeeeeeeeeeeeeeeeeek! Missing dep: appstream-glib >=

On my system i edited configure to require 0.7.6 (which i have) and it

For the record, I just checked current code and actual minimum dep
(relatively to the functions I use from this lib) would be 0.6.7.
I could set a lower value, but really the development is barely started on
this feature, I will use more API soon so it may go back up soon anyway,
and I'm not sure if it is worth just going back and forth on dependency

Note that I originally chose this version 0.7.7 by looking at Debian
Testing, which is our base for deciding whether a version can a requirement
in the development GIMP.
Also this is development code. It is expected to get bumpy. We even
realized this dependency has problems to build on Windows, but it's ok. We
are confident that this will improve. This is not the first time (and won't
be the last) that we improve projects by using them, and in particular that
we make them going cross-platform. :-)


Ah, but I have appstream-glib >0.7.7 installed; built it from source
and installed it into the prefix I use for gimp.

Check there's a .pc file in $PREFIX/usr/lib/pkgconfig/ and also that
the directory containing it is in your PKG_PATH.

If so, check config.log to see what went wrong...

Liam (slave ankh)

Liam Quin - web slave for
with fabulous vintage art and fascinating texts to read.
Click here to have the slave beaten.
gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:
List archives:

ZeMarmot open animation film

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]