[Gimp-developer] XCF error: unsupported XCF file version 7 encountered

I updated glib/babl/gegl/gimp from git a couple of days ago. Then I opened an existing xcf file, worked on it, saved it, and closed GIMP.

The next day I couldn't open the xcf file. The error message is:

XCF error: unsupported XCF file version 7 encountered

I deleted the installation directory, did "git clean -xdf", and rebuilt everything from scratch. The error message was still triggered by making a new xcf file ("File/New"), saving it to disk as anything other than an 8-bit integer image, then closing and reopening it.

This AM I did "git reset" to push babl/gegl/gimp back to the last commit in February and then rebuilt everything. At that point I could save and then reopen any precision xcf file, except the xcf files that had already been saved as version 7.

Then I did "git pull" to bring GIMP (but not babl or gegl) up to date again. And now I can only save, close, and then reopen an 8-bit integer gamma image. Saving any other precision xcf file produces the error message as soon as the file is closed and then reopened.

Checking with exiftool shows:

~/edit/test-xcf-version $ exiftool -s -XCFVersion -FileModifyDate *.xcf
======== new-8i-gamma.xcf
XCFVersion                      : 0
FileModifyDate                  : 2014:03:12 07:25:14-04:00
======== new-32f-gamma.xcf
XCFVersion                      : Unknown (v007)
FileModifyDate                  : 2014:03:12 07:24:09-04:00
    2 image files read

Previously created xcf files show variously
XCFVersion                      : Unknown (v006)
XCFVersion                      : Unknown (v005)

Opening and then resaving a version 5 or 6 xcf file under a new name produces version 7, that can't be reopened.

Is this a bug that affects everyone, or is there something wrong with my installation?

Is there any chance of opening my version 7 xcf files from two days ago?

I'm running 64-bit Gentoo. Just prior to the version 7 problem I had done a complete Gentoo update. Also I had checked the GIMP log and then updated glib to glib from git. I also tried glib-2.39.91.

glib/babl/gegl/gimp are all in a prefix defined by the following:

export INSTALL_PREFIX=/home/elle/code/gimp291/run
export SRC_DIR=/home/elle/code/gimp291/build

Thanks in advance for any help in retrieving my version 7 xcf files, or at least in figuring out how to avoid creating new version 7 xcf files.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]