Re: [Gimp-developer] My plugin doesn't start anymore after upgrading mingw/gcc suite

You know what? I give up, for now.

I spent like an entire day searching for a solution to this problem... and I "solved" it simply by removing 
the current mingw32 package and re-installing an version which still includes gcc 4.7.0 (luckily found on 
another PC).

I can't really focus on a possibile solution, I've everything on the right place (GIMP-dev and GTK-dev 
libraries, in primis) and the only thing that changed was the version of gcc, from 4.7 to 4.8 branch.

With gcc 4.7, compiled for mingw32 on Windows 64bit, I just run the bat command I posted before in order to 
compile every new version of BIMP. 
The resulting 32bit binary is put on the usual GIMP's plugin directory, no matter if 32 or 64bit distribution 
because as far as I know GIMP on a x64 machine can run plugins for both the architectures: That's the reason why I never had problems in distributing a 
32bit-only versions of my plugin. They simply work "everywhere".

On the other hand, if doing the same thing but using gcc 4.8, the resulting 32bit .exe is twice the size of 
the previous one and crashes when loaded by GIMP.

@drawoc: your tip is good, but in order to use gdb I must re-compile GIMP with debug symbols. I've never done 
it before and I haven't got time to solve issues that might arise from this step under Windows. 

So, thank you. Maybe I'll face this problem again in future, but I'd like to deal with other issues for now.
By the way, a new version of BIMP is out, if you're interested:

From: drawoc darkrefraction com
Date: Sun, 6 Oct 2013 17:21:02 -0400
Subject: Re: [Gimp-developer] My plugin doesn't start anymore after upgrading mingw/gcc suite
To: alessandrofrancesconi live it
CC: gimp-developer-list gnome org

It's hard to help you without any additional information. I would
suggest that you grab mingw's gdb and try debugging the plugin with
that. You can try these instructions:
I forget if they work on windows.

Anyway, good luck!

On Sat, Oct 5, 2013 at 5:43 AM, Alessandro Francesconi
<alessandrofrancesconi live it> wrote:

Anyone can give me help? I’m still blocked for this problem. As I said to Partha in private, I can’t 
figure another reason about this, apart from a GCC’s fault.
The fact is that my code worked few minutes before upgrading to GCC 4.8.1, then, without changes, the new 
compiler made it “invisible” to GIMP.

Moreover, the plugin now crashes when queryied by GIMP at startup 

My system is Windows 8 64bit, GIMP 2.6.8.

Can it be related to the 64bit environment? Never had problems before.


Da: Alessandro Francesconi
Data invio: venerdì 4 ottobre 2013 11.12
A: gimp-developer-list gnome org

Hello everyone,

This morning, on my Windows platform, I’ve decided to run a “mingw-get.exe upgrade” command in order to 
give a fresh update to my compiling tools.

The process finished fine and the GCC version changed from 4.7.2 to 4.8.1... but I shouldn't have done it!

I went to my plugin source code (it’s BIMP, by the way), then I run the usual batch command in order to 
compile it with the “new” tools. The compiler ended without errors, but now the plugin is disappeared from 

One strange thing after the upgrade: the filesize of my plugin’s executable changed from 270 KB to 320 
KB... I think I have to add some new options to the compiler, or what?

This is the full command I use to compile my plugin:

Thanks for your attention
gimp-developer-list mailing list
List address: gimp-developer-list gnome org
List membership:
gimp-developer-list mailing list
List address: gimp-developer-list gnome org
List membership:                               

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]