Re: [Gimp-developer] My plugin doesn't start anymore afte r upgrading mingw/gcc suite


Anyone can give me help? I’m still blocked for this problem. As I said to Partha in private, I can’t figure 
another reason about this, apart from a GCC’s fault.
The fact is that my code worked few minutes before upgrading to GCC 4.8.1, then, without changes, the new 
compiler made it “invisible” to GIMP.


Moreover, the plugin now crashes when queryied by GIMP at startup 

My system is Windows 8 64bit, GIMP 2.6.8.


Can it be related to the 64bit environment? Never had problems before.





Da: Alessandro Francesconi
Data invio: ‎venerdì‎ ‎4‎ ‎ottobre‎ ‎2013 ‎11‎.‎12
A: gimp-developer-list gnome org


Hello everyone, 

This morning, on my Windows platform, I’ve decided to run a “mingw-get.exe upgrade” command in order to give 
a fresh update to my compiling tools.

The process finished fine and the GCC version changed from 4.7.2 to 4.8.1... but I shouldn't have done it! 

I went to my plugin source code (it’s BIMP, by the way), then I run the usual batch command in order to 
compile it with the “new” tools. The compiler ended without errors, but now the plugin is disappeared from 

One strange thing after the upgrade: the filesize of my plugin’s executable changed from 270 KB to 320 KB... 
I think I have to add some new options to the compiler, or what?

This is the full command I use to compile my plugin:

Thanks for your attention
gimp-developer-list mailing list
List address:    gimp-developer-list gnome org
List membership:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]