Re: [gedit-list] Ubuntu 9.10 or gedit 2.28.0 kills external tools

At 22:19 +0100 11/2/09, Jef Driesen wrote:
>Doug McNutt wrote:
>> Ubuntu newly upgraded to 9.10, gedit 2.28.0
>> My tools don't work any more.
>> [..]
>> The error returned is:   "Could not execute command [Errno 8] Exec  format error"
>I noticed this too! It seems that the "body" of an external tool needs to be a complete shell script. For instance if I try to create a tool which tries to execute a single command, like
>it doesn't work. But if I specify
>it works for me.

Wonderful.  It works for me too. Thanks for the prompt reply.

The selection window for the tools still converts underlines in the file names to spaces in the menu .

For my curl operations my tools are copying both stdin and stderr from the shell into the text file where I have asked for replacement of the current selection.

I suspect that redirecting the error to /dev/null will fix that except that it was nice to see curl's progress in the bottom window while getting only the contents of the file in the main window.

I'm also getting a response from my rc file for the shell into the text area. It's the message I send when I log in remotely. I'll check some more but the shell in the #! line may being invoked as a login shell by gedit.

My tools that have always started with #!/usr/bin/perl have worked OK though I may not have tried them all.

--> From the U S of A, the only socialist country that refuses to admit it. <--

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]