[gdome]XML or xml namespace in the middle of API, objects and macros


extending style module in libgdome,
I feel uneasy with the gdome_xml_... or GDOME_XML_... namespace.

gdome prefix gdome_ or GDOME_ at all the word from W3C.
e.g. GdomeDOMString for DOMString.
I can understand it, thou I don't like it.

but why one more prefix of xml_ or XML_?
GDOME_XML_IS_STYLSH() is not a good name than just GDOME_IS_STYLSH().

why should I use the xml_ or XML_ prefix in this code?
or may I remove them all?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]