Re: [gdm-list] "gdm accessability registry was not found" = ???

1 - If the way i'm replying isn't correct then pls let me know - sorry - i'm new at mailing lists.

2 -
- Turned on the debug mode
- tried to login suz via KDE menu "switch user"
- error message
- copied part of /var/log/messages to attached file.
"gdm accessibility registry" is not showing anymore
- accessibility is / has been turned off
I also tried:
# su suz
# password . . .
returned> bash: /home/suz/.bashrc :permission denied

# ls -Z /home/suz
# suz homeusergroup -rw-r--r-- user_u:object_r:user_home_t
# chmod 7777 /home/suz
retry su but same message
reset the permissions to 644
Note: the following files are present in /home/suz but not in /home/mik (which logs on perfectly)

On Mon, 01 Oct 2007 15:47:54 +0100, Brian Cameron <Brian Cameron Sun COM> wrote:


- root & user1 can login perfectly
- Any "newuser" has /home/newuser with rw access for user only (r access for its group)
- login of newuser fails "/home/newuser does not exist"
- nxt msg "is gdm accessability registry was not found"
- newuser deleted with associated directories and then recreated => no change to problem

Note that GDM has a RelaxPermissions configuration option.  If set to
the normal, default, value, then GDM is picky about the file ownerships
and permissions of the user's $HOME directory.  If you intend on setting
the ownership/permissions of the user's $HOME directory to something
unusual, then you might need to change this configuration option.  If
you turn on debug (check the debug checkbox on gdmsetup's security tab),
then you should find messages echoed to your syslog (/var/log/messages
or /var/adm/messages depending on your system).

It might be helpful if you could share such syslog debug messages with
us, if it isn't immediately clear to you what the problem is.

Also, I'm a bit confused about the "gdm accessibility registry" was not
found.  Looking through the GDM code, I do not see any messages that
look like this.  Could you explain how you see this message?  Is it in
the syslog, or in a pop-up that shows up?  Are you sure it says "GDM"
in the message?

GDM does try to start the at-spi-registryd for the "gdm" user if you run
GDM with accessibility turned on.  If accessibility is turned on in GDM,
does turning it off make a difference?


Attachment: messages at login
Description: Binary data

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]