Re: [gdm-list] Problem with .ICEauthority

Le vendredi 22 juin 2007 �5:13 +0800, Brian Cameron a �it :
> Jean:
> I'm not sure that this is a GDM issue.  Note that libICE is a part of
> the X consolidation.  I don't see that GDM displays any messages about
> .ICEauthority locking issues.
> I'd recommend that you touch base with an forum (refer to
> and pose your question there.
> Does GDM work better if you leave the UserAuthDir directory is blank?
> If it is blank, then GDM will use the user's $HOME directory.  Note
> UserAuthDir only affects where the Xauth keys are placed and should not
> affect ICEauthority, I'd think.

In that case, things fail even earlier upon execution of xauth.

> Note GDM only has code in daemon/slave.c to ensure that the
> .ICEauthority permissions are set properly.  If so it will call
> fchown to ensure the file is owned by the user and the user's group
> and fchmod to set it to S_IRUSR | S_IWUSR.  Other than this GDM doesn't
> touch the .ICEauthority file.  Therefore, I don't think GDM is the
> source of your problem.

I could fix my problem by adding a line in /etc/gdm/Xsession:
export ICEAUTHORITY=`mktemp /tmp/.iceXXXXXX`

but I don't like to change scripts, it's much better to change a
configuration file IMHO.


> Brian
> > I'm trying to install a debian-4.0 workstation inside a win2003 domain.
> > The users directories are on a windows server and the session ends
> > immediatly with a message saying that .ICEauthority could not be locked.
> > The UserAuthDir has been set to /tmp in the gdm configuration file
> > because the same issue was reported for .Xauthority.
> > I also tried to set ICEAUTHORITY at various places, but no solution I
> > could imagine worked.
> > Does somebody know a solution to this problem, or should I patch gdm so
> > that is sets ICEAUTHORITY?
> > 
> > Thanks
> > Jean

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]