gconftool-2 --makefile-uninstall-rules do not clean /etc/gconf/gconf.xml.defaults?


I am a gentoo user and I just tried Gnome 2.26. I carelessly installed
the whole Gnome into my laptop yesterday and soon uninstalled those
accessories which seems not so useful for me. But I notice that there
are plenty of entries left in the gconf-editor. I tried to restart my
system and did not start X. I reinstalled those parts and manually
gconftool-2 --makefile-uninstall-rules those schema files before I
uninstalled them again. I also cleaned my ~/.gconf directory. But I
still disappointedly found those entries still listed in my
gconf-editor, noticing that /etc/gconf/gconf.xml.defaults/%gconf-tree
contains a lot of things which belong to those purged parts.

One of Gentoo Gnome developers told me that ebuild actually did
gconftool-2 --makefile-uninstall-rules for me while purging. And IMHO
this might be a "feature" of gconf.

I googled a lot about "clean gconf" but find no solution but
gconf-cleaner. But this tool is no longer maintained and is also
deprecated since it can cause rather critical errors. Since gconf-2
lasts for several years, I cannot scrunitize all the emails in the
list. I am wondering that is this expected? Will this be solved in

(I noticing that Ubuntu might also have this problem. I test this on
Ubuntu 8.04 and aptitude purge gnome-keyring and them found those
entries left also.)

Thank you very much.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]