Gconfd/ORBit problem?

Below is a copy of a problem I submitted to the Gentoo Forums with no
success. I am using Gentoo GNU/Linux x86 on a Dell Inspiron 8100. I have
had Gnome running perfectly for many months now before the problem

I have a problem that relates, I think, to gconfd. 

I have been having problems running gnome. It takes a very long time to
load up (>10mins). After logging in at the gdm prompt, the screen clears
and the generic grey gnome background appears. The cursor is still
there. Nothing else happens for a long time. Eventually, Gnome appears
to load as normal. 

After some experimenting, I found that deleting the /tmp/gconfd-hen
directory solves the problem for a single log in, until the directory is
replaced (the user is hen). The issue is for all users. 

If I run an alternative window manager, a good portion of the gnome
programs (Galeon, Epiphany, Evolution) also take a long time to load.
However, once one has loaded (or Gnome has) then they all load at normal
speed, until I log out again. 

Here is the output from strace when I try to load Evolution (in
Blackbox) just before it freezes: 
        munmap(0x414c7000, 95283)               = 0 
        open("/etc/protocols", O_RDONLY)        = 14 
        fcntl64(14, F_GETFD)                    = 0 
        fcntl64(14, F_SETFD, FD_CLOEXEC)        = 0 
        fstat64(14, {st_mode=S_IFREG|0644, st_size=1846, ...}) = 0 
        mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
        MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x400b5000 
        read(14, "# /etc/protocols:\n# $Id: protoco"..., 4096) = 1846 
        close(14)                               = 0 
        munmap(0x400b5000, 4096)                = 0 
        setsockopt(13, SOL_TCP, TCP_NODELAY, [1], 4) = 0 

At which point is freezes for a while, and then continues:     
        poll([{fd=6, events=POLLIN}, {fd=13, events=POLLOUT,
        revents=POLLERR|POLLHUP}], 2, -1) = 1 
        getsockopt(13, SOL_SOCKET, SO_ERROR, [110], [4]) = 0 
        close(13)                               = 0 
        socket(PF_UNIX, SOCK_STREAM, 0)         = 13 
        connect(13, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"},
        110) = -1 ENOENT (No such file or directory) 
        close(13)                               = 0 
        open("/etc/hosts", O_RDONLY)            = 13 
        fcntl64(13, F_GETFD)                    = 0 
        fcntl64(13, F_SETFD, FD_CLOEXEC)        = 0 
        fstat64(13, {st_mode=S_IFREG|0644, st_size=600, ...}) = 0 
        mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
        MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40223000 
        read(13, "# /etc/hosts:  This file describ"..., 4096) = 600 

I also am having problems running Gnucash. Now this problem started at
exactly the same time as the problems above (well, after a logout/login
cycle). This seemed to start occurring when I accidentally unmerged
docbook-xml-dtd-4.1.2. I quickly reemerged the package when I realised
it had deps issues. 

The problem is that the when I try to load a report, the programming
freezes entirely. 

When I run Gnucash under strace, the last few lines before freezing, the
output is as follows:
        mkdir("/home/hen/.gconfd", 0700)        = -1 EEXIST (File
        open("/home/hen/.gconfd/lock/ior", O_RDONLY) = 12 
        fstat64(12, {st_mode=S_IFREG|0700, st_size=393, ...}) = 0 
        mmap2(NULL, 4096, PROT_READ|PROT_WRITE,
        MAP_PRIVATE|MAP_ANONYMOUS, -1,0) = 0x41376000 
        read(12, "3375:IOR:010000001500000049444c3"..., 4096) = 393 
        read(12, "", 4096)                      = 0 
        close(12)                               = 0 
        munmap(0x41376000, 4096)                = 0 
        socket(PF_UNIX, SOCK_STREAM, 0)         = 12 
	{sa_family=AF_UNIX,path="/tmp/orbit-hen/orb-1688068609404224673"}, 40
Now, this points the freeze at some orbit issue. If my understanding is
correct, orbit is intimitely involved in Gconfd (although I have not a
clue how). This would seem to imply some kind of link with the first

Incidently, Gnucash uses gconfd-1, which needs to be started from a

I have tried reemerging both Gconfd and ORBit, with the problem not
being solved. 

Any ideas would be appreciated. 


Henry Gomersall
Trinity College, Cambridge
Mobile: 07764 756059
whg21 cam ac uk

Please avoid sending me any WORD or POWERPOINT attachments.
See http://www.fsf.org/philosophy/no-word-attachments.html

"If your only contribution is to quote another, that is no contibution
at all."

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]