Re: [g-a-devel] API Break? Bad versioning practice? Problems with gail/atk/at-spi

Li Yuan wrote:
On Tue, 2007-01-30 at 21:04 +0000, Bill Haneman wrote:
Hi Elijah, and Li:

Since our atk, at-spi, and gail versions are all < 16, perhaps
we can and should sync the minor number with the gnome release, starting with the next releases for gnome-2.18 beta2 and 2.16.5+

I don't think we need to follow what orca is doing, and sync the micro release and major numbers too, i.e. I don't think gnome-2.19.1 should have "atk-2.19.1", but I do agree that we should:

1) keep the minor number in sync with the gnome release where possible, and
2) (implied by above) use odd minor numbers for 'unstable' releases and even minor numbers for stable.

Sorry that we deviated from this scheme in the past 18 months or so, we used to use odd minor numbers for unstable but just stopped!

Li, does this sound like the right thing to do?

It is OK to me. So I should release atk, gail and at-spi 1.17.91 for
GNOME 2.18.0 Beta 2, right?
Hi Li;

I don't think it is necessary to use the same "micro" release number (.91).

1.17.0 would be fine, or even 1.18.0 if we are sure no API changes will be requested.

I think perhaps 1.17.0 is better for now, since we might ask the release team to let us mark a couple of things as deprecated in 1.18.0 (the community discussion about these small deprecations is still going on).

Best regards,


best regards,


Elijah Newren wrote:

I know the accessibility folks are some of the most overworked and
understaffed (despite their huge importance to the project), so I hope
this doesn't come across as critical.  But there's a problem with
releases that needs to be straightened out.  In short, it's nearly
impossible to tell which versions of gail/atk/at-spi are meant for
stable and unstable releases.  There might be API or other freeze
breaks, or it may just be that the versioning system is very confusing
and stable tarball releases aren't being made.

at-spi-1.17.12 was released for gnome 2.16.1.  at-spi-1.17.16 is the
most recent version.  at-spi doesn't follow GNOME version numbering,
which is suboptimal.  One would normally guess that 1.17.16 doesn't
have any feature/ui/string/api changes or additions and thus is fine
for the 2.16.3 release (given that only the micro version number has
increased).  However, at-spi-1.17.6 depends on atk>=1.13.  (cf.  Lack of following
GNOME versioning makes life difficult here too.  The ChangeLog
indicates that atk-1.13.x includes new API over atk-1.12.x and thus is
not suitable for inclusion in the 2.16.3.

gail has similar problems.  The ChangeLog indicates that 1.9.4 was
specifically for gnome 2.17.4 (while 1.9.3 was specifically meant for
gnome 2.16.1), but in this case I can't tell if there were any
api/feature/ui/string changes or additions.

Thanks for all your hard work,
Gnome-accessibility-devel mailing list
Gnome-accessibility-devel gnome org
Gnome-accessibility-devel mailing list
Gnome-accessibility-devel gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]