API Break? Bad versioning practice? Problems with gail/atk/at-spi


I know the accessibility folks are some of the most overworked and
understaffed (despite their huge importance to the project), so I hope
this doesn't come across as critical.  But there's a problem with
releases that needs to be straightened out.  In short, it's nearly
impossible to tell which versions of gail/atk/at-spi are meant for
stable and unstable releases.  There might be API or other freeze
breaks, or it may just be that the versioning system is very confusing
and stable tarball releases aren't being made.

at-spi-1.17.12 was released for gnome 2.16.1.  at-spi-1.17.16 is the
most recent version.  at-spi doesn't follow GNOME version numbering,
which is suboptimal.  One would normally guess that 1.17.16 doesn't
have any feature/ui/string/api changes or additions and thus is fine
for the 2.16.3 release (given that only the micro version number has
increased).  However, at-spi-1.17.6 depends on atk>=1.13.  (cf.
http://bugzilla.gnome.org/show_bug.cgi?id=400440).  Lack of following
GNOME versioning makes life difficult here too.  The ChangeLog
indicates that atk-1.13.x includes new API over atk-1.12.x and thus is
not suitable for inclusion in the 2.16.3.

gail has similar problems.  The ChangeLog indicates that 1.9.4 was
specifically for gnome 2.17.4 (while 1.9.3 was specifically meant for
gnome 2.16.1), but in this case I can't tell if there were any
api/feature/ui/string changes or additions.

Thanks for all your hard work,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]