Re: garnome-2.11-20050616.1615 doesn't build on Ubuntu Hoary

> > checking for libgnomeui-2.0 dbus-glib-1 >= 0.31 hal >= 0.5.0 gtk+-2.0 >=
> > 2.6.0... Requested 'dbus-glib-1 >= 0.31' but version of dbus-glib is
> > 0.23.4

Build dbus from bootstrap.

> > How badly would I break my Ubuntu install if I manually built dbus-0.33
> > from
> Not sure, but I guess that the Ubuntu provided apps (which are using
> hal/dbus) won't be happy about a new dbus version.
> AFAIK the API changed and isn't downward compatible. FWIW, there seems
> to be agreement to move to dbus 0.3x for GNOME 2.12 -- which requires
> some (supposedly) easy adjustment in the existing apps using dbus.

Now that the little cartoon like light above Pauls head enlightens the
entire channel, it's time to clarify my statements above. ;)

Sure, the apps using dbus shipped by Ubuntu likely won't be happy about
a different dbus API. But that basically just means, don't use them (the
old ones) in a mixed environment while using your shiny new unstable
GNOME 2.11.something.

You'll need to stop the dbus 0.2x while using GNOME 2.11.x and fire up
the GARNOME provided dbus 0.3x.

If I understood and remember this correctly, you even can start dbus as
user in your GARNOME session, but you will miss some funky features

So in conclusion: No, it should not harm your system to build dbus 0.3x
and friends. :)

Happy building...


char *t="\10pse\0r\0dtu\0  ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]