Re: f-spot 0.4.0 hangs (ubuntu gutsy) - SOLVED

Ruben Vermeersch wrote:
> On Thu, 2007-10-11 at 10:52 +0200, Lorenzo Milesi wrote:
>> Emanuele Olivetti ha scritto:
>>> Here is the "file" command running on db:
>>> foto arale:~$ file .gnome2/f-spot/photos.db
>>> .gnome2/f-spot/photos.db: SQLite 2.x database
>> Probably this is your problem. It should be 3.x. You should run
>> f-spot-sqlite-upgrade.
>> If it works we'll ask Stephane why it happened and if it's a normal
>> situation.
> It's not, I'm experiencing it as well, with an SQLite 3 database.

After some attempts I found the source of the problem: I guess
that during the ubuntu upgrade (feisty->gutsy) the executable "sqlite"
disappeared. Only "sqlite3" is present. Since f-spot-sqlite-upgrade
uses both of them (dumps using sqlite and rebuilds the db using
sqlite3) it fails since "sqlite" is missing. Installing sqlite
(apt-get install sqlite) solved the problem.

To be precise there is one action more action I had to perform
before upgrading sqlite.db : since I killed f-spot last time (it hung),
the db was not OK (a .journal had to be replayed). Just running
f-spot and exiting cleanly fixed this issue.

1) run f-spot and exit just after
2) install sqlite (apt-get install sqlite)
3) run f-spot-sqlite-upgrade
4) use f-spot happily :)

Thanks for helping me solving the issue. I couldn't access my
linux box for some days, that's why I was so slow in my answers.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]