Re: Configure Error

Paulo André wrote:
On Sat, 2005-03-26 at 23:08 -0500, Kevin T. Neely wrote:

Hi there,

I am running Suse 9.2 and attempting to configure f-spot 0.12.

I have gnome running and through YaST, I believe I have all the development libraries installed.

It does not say you do not have libgnome, what it says is that somewhere
along the way that list of dependecies is not entirely met by your
system. This can be either because you don't have the required
dependency installed at all or simply because the corresponding .pc file
can't be found - it may be in a non-standard location. In the latter
case, locate the required .pc file and adjust the PKG_CONFIG_PATH
accordingly to include that location.

When I originally ran configure, it could not find mono.pc, so I created a symbolic link from where I thought it was looking (/usr/lib) to where the file actually existed (/usr/lib/pkgconfig). After doing that, Configure gets farther, but I am receiving the error I mentioned earlier. Here it is with a bit more information:

checking for mono.pc... found
checking for Mono.Data.SqliteClient.dll... found
checking for Mono.Posix.dll... found
checking for System.Runtime.Remoting.dll... found
checking for System.Web.dll... found
checking for System.Web.Services.dll... found
checking for libgnome-2.0 >= 2.2 libgnomeui-2.0 >= 2.2 libexif >= 0.5.7 libexif < 0.7.0 gtkhtml-sharp >= 1.0 gconf-sharp >= 1.0 glade-sharp >= 1.0 gtk+-2.0 >= 2.4... Package gtkhtml-sharp was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkhtml-sharp.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkhtml-sharp' found

configure: error: Library requirements (libgnome-2.0 >= 2.2 libgnomeui-2.0 >= 2.2 libexif >= 0.5.7 libexif < 0.7.0 gtkhtml-sharp >= 1.0 gconf-sharp >= 1.0 glade-sharp >= 1.0 gtk+-2.0 >= 2.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

If I adjust the PKG_CONFIG_PATH to be like so: './configure PKG_CONFIG_PATH=/usr/lib/pkgconfig' I get a similar message to that I was getting before I added the symbolic link:

appending configuration tag "F77" to libtool
./configure: line 19751: GNOME_COMPILE_WARNINGS: command not found
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the *** exact error that occured. This usually means GLIB is incorrectly installed.
checking for mono... /usr/bin/mono
checking for mcs... /usr/bin/mcs
checking for mono.pc... configure: error: missing the mono.pc file, usually found in the mono-devel package

thank you,

In vino veritas

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]