Re: Configure Error
- From: Paulo André <paulo r l andre gmail com>
- To: "Kevin T. Neely" <ktneely astroturfgarden com>
- Cc: f-spot-list gnome org
- Subject: Re: Configure Error
- Date: Mon, 28 Mar 2005 15:07:21 +0100
On Sat, 2005-03-26 at 23:08 -0500, Kevin T. Neely wrote:
> Hi there,
> I am running Suse 9.2 and attempting to configure f-spot 0.12.
> I have gnome running and through YaST, I believe I have all the
> development libraries installed.
> When I run configure, I get the following message:
> configure: error: Library requirements (libgnome-2.0 >= 2.2
> libgnomeui-2.0 >= 2.2 libexif >= 0.5.7 libexif < 0.7.0 gtkhtml-sharp >=
> 1.0 gconf-sharp >= 1.0 glade-sharp >= 1.0 gtk+-2.0 >= 2.4) not met;
> consider adjusting the PKG_CONFIG_PATH environment variable if your
> libraries are in a nonstandard prefix so pkg-config can find them.
Usually when the configuration process breaks, there's a bit more of
error output directly above what you pasted which should help pinpoint
the problem more accurately (it should exactly what .pc file couldn't be
found). Could you please provide that, in case it exists?
> Although it says I do not have libgnome, if I try to install it with,
> say, rpm, I get:
> package libgnome-2.6.1-6 is already installed, I just cannot seem to
> figure out how to let configure know that it's there.
It does not say you do not have libgnome, what it says is that somewhere
along the way that list of dependecies is not entirely met by your
system. This can be either because you don't have the required
dependency installed at all or simply because the corresponding .pc file
can't be found - it may be in a non-standard location. In the latter
case, locate the required .pc file and adjust the PKG_CONFIG_PATH
accordingly to include that location.
Paulo André <paulo r l andre gmail com>
] [Thread Prev