Re: frozen with error message loop

On Saturday 11 June 2005, Steve Rosen wrote:

> I'm not an F-Spot developer, but I assume that F-Spot now has your CD
> photos in its database so it keeps trying to re-read the CD. Any F-Spot
> developers want to confirm? Here are some ideas to try:
> - Have you tried simply removing the CD from the drive and then starting
> F-Spot? 

Yes, it makes no difference even on re-boot.

> If that works, remove the CD photos from the catalog (select the 
> photos in F-Spot, right-click, select "Remove From catalog").

Even with the error message on the screen, I just tried selecting and removing 
the photos as suggested above. They all disappeared after warning me that the 
files would be removed from F-Spot but not the drive. I closed F-Spot and 
then closed the error message. Next, I re-opened F-Spot with success (read 
hear no more error message). I will now move on to trying to learn how to use 
the program.

Steve, thank you so much for the suggestions. Is there any documentation or 
tutorials for F-Spot? I use KDE and am familiar with the man pages but 
wouldn't have thought to look there for gnome documentation.

How would someone new to F-Spot, such as myself, figured this out on my own. 
Thank goodness for such e-lists.


> - Try putting in a formatted (burned) CD that has no files on it (maybe
> a CD-RW if you don't want to waste a CD-R). Maybe F-Spot won't fail when
> trying to read an empty CD. Then you can remove the CD photos from the
> catalog.
> - Last resort: You could try manually editing the F-Spot photo database
> to remove the CD photo files. The F-Spot database is stored in
> ~/.gnome2/f-spot. It's an SQLite database, and can probably be edited
> using SQLite commands, though I've never tried. But it might be better
> to try this than wiping out the photo database -- you'd lose all your
> tag info and photo edit info.
> Let me know what happens!
> Steve
> julie wrote:
> >Help, please ... I'm stuck in a loop that even rebooting doesn't resolve.
> >
> >Here's the error message: "The application "f-spot" has quit unexpectedly.
> > You can inform the developers of what happened to help them fix it. Or
> > you can restart the application right now." There are two options to
> > choose from, a button for "restart application" and one for "close".
> >
> >I have tried "restart application" but the error message is still there.
> >Selecting the "close" button and then restarting the application also
> > retains the error message. Even rebooting the system has not eliminated
> > the error message.
> >
> >I installed F-Spot using F-spot-0.0.13-1mdk.i586.rpm on a Mandrake LE 2005
> >system. The system has 526MB memory and a Sempron 2500 CPU on a PC Chips
> >M825G motherboard with on board graphics.
> >
> >Here's what I was doing when this error message appeared:
> >
> >I opened F-Spot and tried opening a folder of JPGs located on a CD. (The
> > CD is one I burned and is easily accessable using GIMP or Kwickshow.) The
> > error message appeared half-way through loading the files.
> >
> >Perhaps it would have been better to open a file on my hard drive... but
> > being stuck in an error message loop, I am unable to test this.
> >
> >Other than un-installing F-Spot and re-installing it, do anyone have any
> >suggestions?
> >
> >Sincerely,
> >Julie Owens
> >_______________________________________________
> >F-spot-list mailing list
> >F-spot-list gnome org
> >

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]