Re: [Evolution] Evolution stopped working altogether

The replies didn't reach me via e-mail, so I looked them up in the archive.

I took your advice to set some environment variables (tcsh syntax):

$: setenv Malloc 1

Then I ran evolution from the command line with no options:

$: Evolution

(evolution-alarm-notify:46040): GLib-GIO-WARNING **: 14:18:43.183: Your application did not unregister from D-Bus before destruction. Consider using g_application_run().
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

If I run it from the root account instead of my own account, it doesn't complain about not unregistering from D-Bus, but the complaint about 'std::bad_alloc' remains.

I tried to downgrade the recently-upgraded packages that appeared to be related to WebKitGTK, all claiming to be security (output from "grep webkit /var/www/dpkg.log.1 attached) using, e.g.,

$: apg-get install gir1.2-webkit2-4.0:amd64=2.32.4-1~deb10u1

but the Debian update server said the version doesn't exist.

Milan wrote

"Some of those updated packages broke Evolution."

That's a good argument for a statically-linked code, if only you could do it.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]