Re: [Evolution] Issue with read only calendars using CalDav SSL (3.10.4)

Thanks Pete, 

On console I get the error "camel-WARNING **: Failed to initialize NSS 
SQL database in sql:/etc/pki/nssdb: NSS error -8187". A bit of 
research led me to download a more recent version of evolution 
(3.13.4). Unfortunately it didn't make a difference. 

I also use evolution-ews for another account, I tried purging this and 
still no difference.

The full log on evolution-calendar-factory doesn't give any errors or 
warnings. It connects, authenticates, requests and downloads events 
Evolution won't even let me attempt to set up an event on this 
calendar ("Event cannot be edited, because the selected calendar is 
read only"). Other calendars work fine, just the CalDAV one has this 
issue. I also use read-only "on the web" calendars and presumed 
evolution was getting confused somehow (they do appear correctly).

Not sure where to go from here.


On Thu, 2014-09-04 at 15:11 +0100, Pete Biggs wrote:
On Thu, 2014-09-04 at 14:52 +0100, Ben Kirman wrote:
 Hi there, I've recently changed machine and moved to Evolution 
 from 3.2.3 and cannot write to CalDav calendars.

 I can add the calendar fine, events appear correctly, but when 
trying to
 create an event I get an error about the calendar being read only.

 This is not the case. The exact same caldav settings work 
perfectly on
 3.2.3, and on Lightning on the new machine. I have a hunch it is
 evolution presuming it is an ical address (which are read only) 
since in
 the configuration it is https://caldav.whatever.

 On 3.2.3 the settings screen is Type: CalDAV, URL:
 caldav://caldav.whatever..., Use secure connection: tick
 On 3.10.4 the settings screen is Type: CalDAV, but for URL it 
won't let
 me type "caldav://", and replaces this with "https://"; whenever I 
 tick the secure connection checkbox.> 
My CalDAV calendars are listed as https:// and work fine for writing.

 All passwords, URL's are correct (since it works in Lightning and 
 but something in the settings means CalDAV calendars are treated 
as read
 only. Any help greatly appreciated!> 
Have ypu run Evolution from the command line?  Any significant 

How about running it with calendar debugging turned on? See - if you can't decode
the debug output, remove all the personal information and post the
output here.


evolution-list mailing list
evolution-list gnome org
To change your list options or unsubscribe, visit ...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]