Re: [Evolution] Evolution webdav sending malformed URI

On Mon, 2010-05-10 at 06:18 -0400, John A. Sullivan III wrote:
On Mon, 2010-05-10 at 10:16 +0200, Milan Crha wrote:
On Sat, 2010-05-08 at 19:20 -0400, John A. Sullivan III wrote:
Can anyone point me in the right direction for both where the URI is
created and general hacking on Evolution?

there is no such thing, Evolution is just huge, and divided in multiple
products. There are some architecture texts on
, but they are probably slightly outdated with respect of 2.30/2.31,
thought the ideas are still the same.

For WebDAV, see evolution-data-server/addressbook/backends/webdav, there
is all you need, except of UI part, which is inside evolution sources,
as a plugin.
I've been recording my (sad) progress in

It looks like the webdav creation of the URI is correct although I
really do not know what I am doing.  Although the process is different
than the correctly functioning caldev process, the end result looks the
same and, substituting the caldev code for the webdav code does not fix
the problem.

It looks like either a SOUP problem or, perhaps more likely, the way
webdav is storing the URI.  I did notice that the caldev URIs are stored
as user%40domain server domain/dav/user domain . . .
while webdav URIs are user domain@server.domain/dav/user domain . . .

Perhaps SOUP is misinterpreting that.  However, so far, if I change the
syntax in the %gconf.xml, I fail authentication.  Any ideas as I'm
really beating my head bloody on this one.  Thanks - John
The patch you provided seems to have worked but has revealed the next
couple of issues.  It URI seems properly formed.  I have removed the
strange /etc/hosts file entry.  I can retrieve contacts without it.

However, now I must ensure I do NOT add a terminating "/" to the URI or
it fails.  I Cannot fully verify the path via packet trace as the
traffic seems to insist on using SSL.  I've set all the sources to http
and %gconf.xml so use_ssl=0 and I've restarted evolution-data-server
several times.  However, packet traces all seem to be https.  We are not
enforcing redirection to https within Zimbra (we disabled it for this
testing).  The messages inside Zimbra seem to indicate a properly formed

The biggest new problem besides the 75 second delay when creating new
contacts referenced in a separate thread is that new contact creation is
not working.  The Evolution dialog returns successfully.  The Zimbra
logs say the contact is created.  If I search for it in Evolution, I can
find it.  However, it is not displayed in Evolution; it is not displayed
in Zimbra and a search in Zimbra (using the web interface) does not find

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]