[Evolution] Need to debug connecting to Exchange Global Address List via LDAP

Hi all;

I'm trying to create a new Address Book in Evolution (I've tried both
2.26 and 2.27.92) which attaches to my Exchange server using LDAP.  I
was able to get this to work in Thunderbird on Linux so it could in
theory work.

When I try it in Evolution, though, I am not able to resolve any

What I did was create a new address book of type LDAP, use the same
server name I used in thunderbird along with the default port (again
same as thunderbird).  I set it to "No encryption", with a login method
of "Using email address" then entered my corporate email address.  On
the Details tab I used a search base of "DC=<company>,DC=com" which is
the same thing I used in thunderbird.

I left the rest as the default (search scope: One; no search filter).

When I do this, I get asked for a password and I use my Exchange
password (again, same as thunderbird).  It seems to be accepted; at any
rate I get no error dialog.

However, no matter what I do I cannot successfully search.  I can't use
the Search bar in the Contacts window; no matter what I type nothing is
returned.  If I start a new email address and click the address header
("To:" etc.) then select the LDAP address book and enter text to match,
nothing is returned.

I've googled but haven't been able to find anything.

So, the first question is does anyone have this working and if so, can
you give me a hint?

The second question is, what kind of debug logging can I enable and how
do I do it?  I tried E2K_DEBUG=5 and CAMEL_DEBUG=all which prints a lot
of stuff, but nothing related to LDAP (the string "ldap" doesn't appear
in the output, and neither does my LDAP server name appear.  Is there
more logging I can turn on somehow?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]