[Evolution] evolution 2.21.92 and gtkhtml-3.17.92 NOT compiling under opensuse10.3

ïhi evolution-developers ;-)

i found in bugzilla the following bug and it's solution:

i also have this problem.

and i want to get this solution.

i am using opensuse10.3 x86_64.

since the opensuse10.3-supplied evolution version didn't work very well,
i always built evolution by my own in the past and today.
for this reason i downloaded all necessary source-packages from
and then configured and made them.

this worked until (and including) evolution version 2.21.3.
this is the last version which i was able to build myself.

as i read in

"Bug fixes:
        #432885: Fix to subscribe to other user's folders (Bharath)"

i came to this bugzilla-entry.

i wanted to build this new version 2.21.92 because it solves a big
problem for me, because i need to open exchange-calenders of my

so i downloaded the following source-packages:

then made glib-2.15.6 with:
./configure --enable-static
make install

then made libsoup-2.3.4 with:
./configure --enable-ssl
make install

then made libbonobo-2.21.90 with:
make install

then tried to make gtkhtml-3.17.92 with:

make stopped with:
undefined reference to `g_assertion_message_expr'
/usr/local/lib/libsoup-2.4.so: undefined reference to `g_checksum_free'
/usr/local/lib/libsoup-2.4.so: undefined reference to
/usr/local/lib/libsoup-2.4.so: undefined reference to
/usr/local/lib/libgio-2.0.so: undefined reference to
/usr/local/lib/libgio-2.0.so: undefined reference to `glib_gettext'
/usr/local/lib/libgio-2.0.so: undefined reference to
./.libs/libgtkhtml-3.14.so: undefined reference to `g_assertion_message'
/usr/local/lib/libsoup-2.4.so: undefined reference to `g_checksum_new'
/usr/local/lib/libgio-2.0.so: undefined reference to `g_warn_message'
/usr/local/lib/libgio-2.0.so: undefined reference to
collect2: ld returned 1 exit status
make[2]: *** [testgtkhtml] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/packages/SOURCES/gtkhtml-3.17.91'
make: *** [all] Error 2

i didn't find any hints/solutions to that.
what error is this?
what can i do?
do i need some more of the new 2.21 gnome-source-packages?
should i update to the gnome-unstable-repo foun at
http://download.opensuse.org/repositories/GNOME:/UNSTABLE/openSUSE_10.3/ ?
what do i need to do to build evolution 2.21.92 on opensuse10.3?
i don't want to wait for opensuse11.
i need a fully working evolution now.
there are some repos in
http://ftp5.gwdg.de/pub/linux/suse/opensuse/repositories/home:/ which
provide newer version of evolution for opensuse10.3, but none of them
provides a rpm for evolution-exchange.....
and none of them offers this latest release 2.21.92.

can anybody of you guys help me?
thanks in advance.
einen schÃnen Tag noch, & bitte kein TOFU (http://de.wikipedia.org/wiki/TOFU)
DI Rainer Klier
Abteilung IT - Entwicklung
ECOLOG Logistiksysteme GmbH                 BauernstraÃe 11, A-4600 Wels
Tel. ++43/7242/66200                        Fax ++43/7242/66200-200
mailto:rainer klier ecolog at                        http://www.ecolog.at
Fb-Nummer 171431f                           Landesgericht Wels

A member  of 

This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]