Re: [Evolution] Evolution crashing when trying to copy sent emails in specific folder.

I finally manage to understand why my evolution was always crashing
when trying to send emailsâ

Basically, the problem seems to appear because I want to save a copy
of the sent email in my INBOX/Sent folder.
I connect to this IMAP account using a secure connection while the
smpt server is a normal connection. The problem seems to occur when
evolution tries to copy the sent message to this IMAP account which
is using a secured connection, because the email does get sent but
it crash afterward.

There was a bug like this in Evolution file on bugzilla. Please check:

This has been fixed tough. (please find the patch attached in the bug)

I beg to differ.

Partha, according to your comment #35 on this bug, the patch was
committed to HEAD only. Thus, as far as the users are concerned, this
bug is NOT fixed.

This is a crasher bug. And there is a fix. Why don't you commit this to
the stable branch as well?

*Please, remember to fix important bugs in the stable branch as well.*

Another note: Pointing users to source code fixes is pointless in almost
all cases. This is the *users* list, not the hackers list. Please, think
about the difference...

This bug can occur if you have your Sent folder in some account which
has not been enabled when you try to send a mail. 

Is it possible for you to get a stack trace of the crash??

...bugging master

char *t="\10pse\0r\0dtu\0  ghno\x4e\xc8\x79\xf4\xab\x51\x8a\x10\xf4\xf4\xc4";
main(){ char h,m=h=*t++,*x=t+2*h,c,i,l=*x,s=0; for (i=0;i<l;i++){ i%8? c<<=1:
(c=*++x); c&128 && (s+=h); if (!(h>>=1)||!t[s+h]){ putchar(t[s]);h=m;s=0; }}}

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]