RE: [Evolution] Problems sending smtp mail in Evo 1.4.5 and 1.5.0

On Fri, 2004-04-30 at 14:54 -0400, Rade Trimceski wrote:
Jeff --

Thanks for the reply. According to the system administrators of the
email server and the directions they give online the smtp server doesn't
require SSL authentication when accessed from within the network but
_does_ require SSL authentication when accessed from outside the

According to the server admins:
                                 port  from   from elsewhere
SMTP server name:  25    SSL optional   TLS/SSLv.3
required and password authentication required

So, if I trust what they say then the server not only supports but
requires SSL from outside the network. Now there is no mention of
another port for SSL enabled trafic, does that mean that both SSL and
non SSL trafic go on port 25? I'm lost, clueless and frustrated :))).

yes, it means that their SMTP server presumably supports the STARTTLS extension and thus uses port 25 for both.

Try changing your "Use SSL" option for SMTP to "Whenever Possible" instead of "Always" if that is what it is already set as. "Whenever Possible" uses STARTTLS and doesn't even attempt the high port.



-----Original Message-----
From: Jeffrey Stedfast [mailto:fejj ximian com] 
Sent: Friday, April 30, 2004 2:28 PM
To: Rade Trimceski
Cc: evolution lists ximian com
Subject: Re: [Evolution] Problems sending smtp mail in Evo 1.4.5 and

Sounds like from outside the network, your server doesn't support SSL
(eg. perhaps the high port is only accessable from within the network).


On Fri, 2004-04-30 at 08:21 -0400, Rade Trimceski wrote: 
Hello all --

I've been working at this problem for quite some time and I can't get
anywhere so any help I can get will be greately appreciated.

My setup:
Redhat 9 + Evolution 1.4.5. Evolution accesses a pop3/smtp email server
that requires authentication and SSL support. (the email server resides
my university's campus).

When I'm at school where the dhcp server recognizes my MAC address I
no problem sending or receiving email.

When I'm at any other place I cannot send an smtp message through my
server but under windows using Outlook I can (so I know it's not a
problem). When I try to send an email off campus I get the following
from Evolution:

Error while performing operation:
Failed to connect to SMTP server in secure mode: server
appear to support SSL

Interestingly, if I try to send an email from offcapus location (and I
can't) the message is left in Outbox. Next time I'm on campus, when i
to send the message I get the following warning message from evolution
the message is sent (when I hit ok):

SSL Certificate check for

Issuer:            OU=Secure Server Certification Authority,O="RSA Data
Security, Inc.",C=US
Subject: ,OU=Distributed Computing
Services,O=Michigan Technological University,L=Houghton,ST=Michigan,C=US
Fingerprint:       93:d8:d8:f7:08:2f:6b:ed:8d:a9:5d:05:2d:4f:22:39
Signature:         BAD

Do you wish to accept?


This same thing happens with Evolution 1.5.0 so I have a feeling my
distribution is involved in causing the problem as much as Evolution is.

Any help will be greatly appreciated (Cc me on reply, I'm not subscribed
to the list).

P.S. If there is any other useful info that I can provide I will be
to do so.

evolution maillist  -  evolution lists ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]