[Evolution] URL Handling in Evo or Gnome in general


I just set my gnomecc URL handling to:
 ps x |grep -q '[m]ozilla' && mozilla -remote "openURL("%s", new-tab)"
|| mozilla "%s"

Which if it worked would start a clicked link in a new tab or
if mozilla isn't running start mozilla with the link.

This works great in my KDE applications but in Evolution I get
the "your profile is allready used" and I need to start a new profile..
this sucks.. so I wonder if this is a mozilla issue or a Evolution issue
or a Gnome issue.. 

The strange thing is it's only evolution causing this problem.
if I run  mozilla -remote "openURL(http://www.google.com, new-tab)"
from the Konsole I open the URL in a new tab for mozilla.. 
why wont Evo/Gnome use the same session of mozilla that's allready
started? If I let Evo start mozilla it still doesn't work...
gnomes-remote-moz opener or whatever doesnt help either..

Something has to be done!

Mårten Woxberg <marwo264 student liu se>
University of Linköping

Attachment: signature.asc
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]