Re: [Evolution] strange 'Fetching Mail' error

On Fri, 2002-09-13 at 15:09, Bill Wagner wrote:
Not Zed said:
Try removing the mbox.ev-summary file. if that doesn't work, try
checking the end of the mbox file.  1.0.2 has some minor mbox problems
which can report spurious errors (got to do with missing \n's between
messages or at the end of the mailbox).

Hrm, well, neither of those worked for me.  So I figured just converting
everything into maildir format would solve this problem (shouldn't it?)

yeah it should solve that problem.

You can do it in different ways.  You can change an existing single
folder to maildir format, goto file->folder->properties when the mailbox
is open.

Ok, that seemed to work great!

Ooof, I just tried pulling down my mail and now it's saying:

Error while 'Fetching Mail':
Cannot append message to maildir folder:
/home/<me>/evolution/local/Inbox/mbox/tmp/XXXXXX.XXXX.<hostname>: No such
file or directory

Any ideas on this one?  And I thought I was so close! :(

did you try restart evo too?  (1.0.2 is so old i wouldn't be surprised
if the reconfig had some problems like this).

But a better way is to add a new 'account' of type 'maildir' and just
point it to your maildir tree.  It assumes various things about the
maildir tree (i.e. that subdirs are dirs, and not cyrus format), and in
1.0.8 it doesn't refresh very reliably if something else adds mails (you
need to change folders i think), but otherwise it works.  1.2 should be
much better with this.

Ah, but this is already presuming that the tree is _already_ in maildir
format, right?

yeah, its for ppl who use procmail more i guess.

Thanks for your help,

Did you hear that, Marge?  She called me a baboon!  The stupidest,
ugliest, smelliest ape of them all!

                -- Homer Simpson
                   Lisa's Substitute

evolution maillist  -  evolution ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]