Re: [Evolution] Encrypted attachments with Evolution 0.14 do not work

On Tue, 2001-10-02 at 12:27, Jeffrey Stedfast wrote:
There weren't any encryption changes between 0.13 and 0.14 as far as I
can remember.


I have now tested sending pgp encrypted attachments using Evo 0.14 (the
Red Carpet version from last week) from 3 separate computers and the
results are a non-functioning message when received on a non-Evo email
program.  All 3 computers had worked with Evo 0.13 and are SuSE 7.2
systems with the Red Carpet upgrade from 0.13 to 0.14.  Between the Evo
computers sending encrypted attachments works fine and the Evo computers
can all properly receive encrypted attachments from other emailers.  The
problem appears to be limited to Evo sending encrypted attachments to
non Evo emailer programs.

To the best of my knowledge the only changes to the 3 computers I tried
to send the Evo encrypted files from were that the computers were
upgraded using Red Carpet after ver 0.14 became available.  (Other
updated programs from Ximiam occured at the same time such as Control
Center.)  All 3 computers had been able to send encrypted attachments to
non Evo systems when using Evo 0.13

Below is an example of an encrypted message sent from Evo 0.14 to a non
Evo email program.  Note that the pgp encrypted attachment does not show
as a separate attachment as it should but is included in the body of the
email.  This little example shows some of the header, the body of the
email and what appears to be the attached file.  (The information about
content type does not typically show up with the opened encrypted


Subject: from Linda's machine
From: Linda Sanford <lsanford telusplanet net>
To: Ralph Sanford <rsanford telusplanet net>
Content-Type: multipart/encrypted; protocol="application/pgp-encrypted";
X-Mailer: Evolution/0.14 (Preview Release)
Date: 02 Oct 2001 20:57:47 -0600
Message-Id: <1002077868 1179 6 camel lsanford>
Mime-Version: 1.0

Content-Type: text/plain
Content-Transfer-Encoding: 7bit

test from Linda's machine using Evo 0.14 of pgp encrypted attachment to
computer with WinNT and pmmail.

Content-Type: application/msword
Content-Disposition: attachment; filename=staff_home_numbers.doc
Content-ID: <1002077620 1137 1 camel lsanford>

etc., etc.


On Mon, 2001-10-01 at 20:41, Ralph Sanford wrote:
I recently tried to send attachments with my email from Evolution 0.14
encrypted using pgp.  What the recipients received was an encrypted
email which when decrypted had the attachment included within the body
of the email (not as an attachment) and the attachment appeared to
remain encrypted.  The 3 recipients have not changed their systems since
the last encrypted mails were sent successfully and all 3 recipients
have reported the same problem.  The only change I can think of is that
I upgraded from Evo 0.13 to 0.14 via Red Carpet.

All the recipients are using pgp 6.5.8, the keys were exchanged years
ago and have not changed.  I believe all the recipients are using PMMail
as their email program.  Until yesterday the use of encrypted mail
between us worked without problems.

My system is SuSE 7.2 with pgp 6.5.8.  The evolution is 0.14 as
downloaded last week using Red Carpet.

Has there been a change to the encryption methodology of Evolution? 

Should I change my evolution setting in some manner?

Have other user successfully sent encrypted attachments using evolution
0.14?  If I send encrypted attachment using evolution from my computer
to my wife's computer also using evolution then the attachments are
received correctly at her computer.  However the majority of my email
recipients are not using evolution as their email package so this is not
as significant as being able to communicate with other users.

Any suggestions?  Or does some one know how to back grade to evolution

Ralph Sanford       -       If your government does not trust you,
rsanford telusplanet net   -   should you trust your government?

DH/DSS Key   -   0x7A1BEA01

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]