Re: [Evolution] Evo 0.10 hangs with IMAP servers

On 15 May 2001 10:00:44 +0930, Not Zed wrote:
Its usually more useful getting backtraces of all the threads.
And also running evolution-mail with debug on (used to be setting
CAMEL_VERBOSE_DEBUG=1 in the env before running it).

This is what I did.  I one term I ran "CAMEL_VERBOSE_DEBUG=1 gdb
evolution-mail" and in another just "evolution".  After reading and
sending some mails it hung, so I hit control-c and printed a backtrace.

sending : A00601 LIST "" "mail/OneEighty/Company"
received: * LIST (\NoInferiors \UnMarked) "/" mail/OneEighty/Company
received: A00601 OK LIST completed
sending : A00602 LIST "" "mail/OneEighty/Web Site"
received: * LIST (\NoInferiors \UnMarked) "/" "mail/OneEighty/Web Site"
received: A00602 OK LIST completed
sending : A00603 LIST "" "mail/sent-mail"
received: * LIST (\NoInferiors) "/" mail/sent-mail
received: A00603 OK LIST completed
sending : A00604 LIST "" "mail/Mailing Lists/Dia"
received: * LIST (\NoInferiors) "/" "mail/Mailing Lists/Dia"
received: A00604 OK LIST completed
sending : A00605 LIST "" "mail/drafts"
received: * LIST (\NoInferiors) "/" mail/drafts
received: A00605 OK LIST completed

  -- I hit control-c here --

[Switching to Thread 12063]

Program received signal SIGINT, Interrupt.
0x40883deb in __sigsuspend (set=0xbf3ffaa8)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
48      ../sysdeps/unix/sysv/linux/sigsuspend.c: No such file or
(gdb) bt
#0  0x40883deb in __sigsuspend (set=0xbf3ffaa8)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
#1  0x40309c82 in __pthread_wait_for_restart_signal (self=0xbf3ffe40)
    at pthread.c:785
#2  0x4030b2c2 in __pthread_lock (lock=0x8143bb8, self=0xbf3ffe40)
    at spinlock.c:68
#3  0x403087ba in __pthread_mutex_lock (mutex=0x8143ba8) at mutex.c:84
#4  0x400505d4 in folder_finalize (folder=0x817e888, event_data=0x0, 
    user_data=0x81436f0) at camel-store.c:181
#5  0x400491b6 in camel_object_unref (obj=0x817e888) at
#6  0x40a4ac2b in camel_imap_command (store=0x81436f0, folder=0x817e798,
    ex=0x0, fmt=0x40a52f69 "NOOP") at camel-imap-command.c:91
#7  0x40a4c9bf in imap_sync (folder=0x817e798, expunge=0, ex=0x0)
    at camel-imap-folder.c:598
#8  0x400384f7 in camel_folder_sync (folder=0x817e798, expunge=0,
    at camel-folder.c:266
#9  0x40050dec in sync_folder (key=0x8186358, folder=0x817e798, ex=0x0)
    at camel-store.c:441
#10 0x406c2c1f in g_hash_table_foreach (hash_table=0x8143b28, 
    func=0x40050dc0 <sync_folder>, user_data=0x0) at ghash.c:300
#11 0x40050e41 in store_sync (store=0x81436f0, ex=0x0) at
#12 0x40050ee6 in camel_store_sync (store=0x81436f0, ex=0x0)
    at camel-store.c:467
#13 0x40a510bc in get_folder_info (store=0x81436f0, top=0x0, fast=0, 
    recursive=1, subscribed_only=1, ex=0x834edc0) at
#14 0x40050fe3 in camel_store_get_folder_info (store=0x81436f0, top=0x0,
    fast=0, recursive=1, subscribed_only=1, ex=0x834edc0) at
#15 0x80800fd in mail_do_transfer_messages ()
#16 0x807dd86 in mail_msg_wait ()
#17 0x4005dbe5 in thread_received_msg (e=0x8136e78, m=0x834eda8)
    at e-msgport.c:468
#18 0x4005dd0a in thread_dispatch (din=0x8136e78) at e-msgport.c:539
#19 0x40307b85 in pthread_start_thread (arg=0xbf3ffe40) at manager.c:241

BTW when it does stop responding, does the stop button work/etc?

The cancel buttons in the mail progress dialog press, but nothing
happens.  I forgot to try stop this time, but I think I tried it before
and it did nothing.

Ross Burton                     Software Engineer
OneEighty Software Ltd          Tel: +44 20 8263 2332
The Lansdowne Building          Fax: +44 20 8263 6314
2 Lansdowne Road                r burton 180sw com
Croydon, Surrey CR9 2ER, UK
Under the Regulation of Investigatory Powers (RIP) Act 2000 together
with any and all Regulations in force pursuant to the Act OneEighty
Software Ltd reserves the right to monitor any or all incoming or
outgoing communications as provided for under the Act

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]