Re: [Evolution] Today's CVS -- There are undefined references in totimezone related functions

I was setting up Mandrake 8.0 on my home computer and tried to build
Evolution. I got a compile error saying it could not find ical.h.
However, that file exists both under /usr/include and in the evolution
source tree. I grabbed an older CVS tree off my work laptop (Mandrake
7.2), and that compiles fine.


On 15 Jun 2001 22:22:05 -0700, Miles Lane wrote:
On 14 Jun 2001 21:57:54 -0700, Miles Lane wrote:

Thanks to all who replied.  Your instructions worked.  
I'm not sure why the make didn't successfully figure
out what all needed to be remade.  I also *thought*
I did a "make clean" after my last build, but I guess
I didn't.

Thanks again for your help!


Whoops.  It turns out I was wrong.  When I sent the note
saying things were working, I actually hadn't gotten to 
building cal-util (I thought I had).  When I tried to build
cal-util, I hit the error again.  I have tried doing 
"make clean all" in ../libical, but it doesn't help.  I have
also tried cvs updating my evolution source tree.  That also
hasn't helped.  Any other ideas?

make[3]: Entering directory
/bin/sh ../../libtool --mode=link gcc  -g -O2 -Wall -Wunused   -o
test-recur  test-recur.o               
../../libversit/                   ../../libical/src/libical/           
-rdynamic -L/usr/lib -L/usr/X11R6/lib -lgal -lgnomeprint -lglade-gnome
-lglade -lxml -lz -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lXi
-lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lgdk_pixbuf -lgtk -lgdk
-lgmodule -lglib -ldl -lXext -lX11 -lm -lgnomecanvaspixbuf -liconv
-lpthread -L/usr/lib -lgthread -lglib -lpthread 
gcc -g -O2 -Wall -Wunused -o .libs/test-recur test-recur.o -rdynamic
./.libs/ ../../libversit/.libs/
../../libical/src/libical/.libs/ -L/usr/lib -L/usr/X11R6/lib
/usr/lib/ /usr/lib/ -ldl -lXext -lX11 -lm -lz
/usr/lib/ -lXext -lX11 -lm -ldl -lz
/usr/lib/ -ldl -lXext -lX11 -lm -lz /usr/lib/ -lz
-lz -lz -lm -lm -ldl -ldl -lXext -lX11 -lm -ldl -lXext -lX11 -lm -lz -lm
-ldl -lXi -lm -ldl -lz -lm -lz -lm -lm -lm -lm -lm
/usr/lib/ -ldl -ldl -lXext -lX11 -lm -ldl -lXext -lX11
-lm -ldl -lXext -lX11 -lm -ldl -ldl -lXext -lX11 -lm
/usr/lib/ /usr/lib/
/usr/lib/ /usr/lib/ -lSM -lICE
/usr/lib/ /usr/lib/ /usr/lib/ -lXext
-lX11 /usr/lib/ /usr/lib/
/usr/lib/ /usr/lib/ -lm -ldb1 -ldl
/usr/lib/ -lpthread /usr/lib/ -lpthread
/usr/lib/ -lpthread
../../libical/src/libical/.libs/ undefined reference to
../../libical/src/libical/.libs/ undefined reference to
undefined reference to `icaltimezone_get_component'
../../libical/src/libical/.libs/ undefined reference to
../../libical/src/libical/.libs/ undefined reference to
../../libical/src/libical/.libs/ undefined reference to
../../libical/src/libical/.libs/ undefined reference to
collect2: ld returned 1 exit status
make[3]: *** [test-recur] Error 1

On 14 Jun 2001 20:09:33 -0400, Damon Chaplin wrote:

I don't know why that would happen. It compiles OK for me.
There error messages are a bit odd as those functions are supposed to
be in

Maybe you could try a 'make clean' in libical, and rebuilding that
from scratch.


evolution maillist  -  evolution helixcode com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]