Re: [Evolution] Snapshots, FTP and Source RPMs

On 08 Jun 2001 12:09:40 -0600, Dan Hensley wrote:
On 08 Jun 2001 13:19:34 -0400, JP Rosevear wrote:
Greetings patient users.

Hopefully by now the enter-crashes-composer bugs will be gone with the
latest updates.

The rpms are now available at:

and the source rpms at<insert-distro-here>/source

The addressbook is now linked against db3, if you are missing your
contacts you can probably upgrade by using db_dump185 <name> | db_load >

I tried the above command, including variations, and it didn't work.
What I'm trying to do now is something along the lines of
strings addressbook.db > tempfile
(edit tempfile to remove certain lines)
Import via Evolution importer.

I was able to do this in the past last time this fiasco came up for me.
Unfortunately now, the Evolution importer doesn't work at all.  I go
through the druid until I get to Import, and when I click on it nothing
happens.  Is the importer known to be broken right now (using CVS from
about 2 days ago)?

IIRC, you said earlier that you installed db 3.1.17 from a RPM, correct?
If so, that didn't work for me.  I had to go to and
download the 3.1.17 source and build and install it.  I was building for
Linux, so I did the following:

        cd build_unix

        ../dist/configure --enable-compat185 --enable-dynamic \
        --prefix=/usr --sysconfdir=/etc

        make all install clean

Others have mentioned on this list that it's probably better to
usr the build command "../dist/configure --enable-compat185" and let
the build get installed in /usr/local/BerkeleyDB (or something like
that).  Then you need to tell your evolution build where to find
these files (that is, if you are building Evolution, too).
I'm not sure how you'd get this working with the snapshot releases.
Though, I imagine someone on this list can give you much better
instructions than I have.

The commands I ran to get the upgraded addressbook.db file were:

        mv addressbook.db addressbook.db.old
        db_dump185 addressbook.db.old > out
        db_load -f out addressbook.db

Remember to run oaf-slay every time you exit Evolution.
There is a problem where oafd and evolution-vcard-importer
hang around and mess things up when you restart the application.

Also, you may need to hit the "View All Contacts" button in order
to get your contacts to display.  At least, I had to.  :-)

Good luck,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]