Re: [Evolution] 2/14 Snap -- Bug reports and comments

Jeffrey Stedfast wrote:

This was never the case... It is in Bugzilla but has not been written

I should have checked bugzilla, sorry about that -- thanks for the info,

(3) Filters again.  Most of the time when I apply filters, the
communication with the IMAP server seems to hang up.  For instance, I
get the digest version of this list, and I have an IMAP folder for
storing the evolution digest mails.  So if I Ctl-Y on a new evolution
digest message to apply a move and delete filter to it, generally it
will sit there (saying keeping connection alive and with the progress
bar bouncing back and forth).  Any further attempts to look at other
messages or folders hangs also.  I tried looking at the output of
evolution-mail (with the verbose debug env variable set for camel) and I
don't see any useful messages about what is going on.

can you get a backtrace with gdb? That'd be useful...

More info on this problem.  I have found that the problem only happens
if I do the following: if I select a message, then click on the window
with the text of the message, THEN click on apply filters (or Ctrl-Y),
then things hang up.  In this situation nothing happens when I click on
any other message or folder -- all I get is a "Keeping Connection Alive"
and the progress bar bounces back and forth.  First, I tried gdb with
the binaries from the Ximian snapshot RPMS -- I actually got a SIGSEGV
in this case (I let it sit there in the "hung" state for a while) -- but
there were no debugging symbols in the binary and there wasn't much
information. Next, I grabbed the latest CVS source and compiled it and
ran a gdb and got it in the hung state.  I waited for quite a while to
see if it would SIGSEGV again for me, but it wouldn't.  So I Ctl-C'd it
and did the backtrace, attached below.  At the beginning of the
following, I did a Ctl-Y (after having clicked in the message text
window), then I tried to click on other messages a few times, waited for
a while, then did the Ctrl-C:

got message in dispatch thread
Single click
emitting cursor changed signal, for uid 6569
selecting uid 6569 (direct)
selecting uid 6569 (delayed)
got message in dispatch thread
setting msg Retrieving message 6569
[New Thread 19537]
*** Message -- STARTING Keeping connection alive
Single click
emitting cursor changed signal, for uid 6566
selecting uid 6566 (direct)
selecting uid 6566 (delayed)
Single click
emitting cursor changed signal, for uid 6569
selecting uid 6569 (direct)
selecting uid 6569 (delayed)
[Switching to Thread 19537]

Program received signal SIGINT, Interrupt.

0x408bedcb in __sigsuspend (set=0xbf1ffc0c)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
48      ../sysdeps/unix/sysv/linux/sigsuspend.c: No such file or directory.
(gdb) bt
#0  0x408bedcb in __sigsuspend (set=0xbf1ffc0c)
    at ../sysdeps/unix/sysv/linux/sigsuspend.c:48
#1  0x40354c62 in __pthread_wait_for_restart_signal (self=0xbf1ffe40)
    at pthread.c:783
#2  0x40351960 in pthread_cond_wait (cond=0x810afa4, mutex=0x810af8c)
    at restart.h:26
#3  0x40022b21 in e_mutex_lock (m=0x810af80) at e-msgport.c:727
#4  0x40a79501 in imap_keepalive (store=0x810aa00) at
#5  0x400790c6 in timeout_cb (data=0x810aa00) at
#6  0x80868d6 in do_camel_timeout (in_data=0x810e8a8, op_data=0x0, 
    ex=0x825e848) at session.c:203
#7  0x807f16d in dispatch (unused=0x0) at mail-threads.c:673
#8  0x40352b85 in pthread_start_thread (arg=0xbf1ffe40) at manager.c:241

Hope this helps, please let me know if I can help with any further


Troy Carter
tcarter princeton edu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]