[Evolution] Trying to compile Evolution, no joy yet..

I've been trying for the last 24 hour (pretty much straight) to get Evolution 
to compile for me.  And no success yet.

First, the system.  It's a base Suse Linux install, on an Sparc Ultra-2.
It had alot of gnome installed already, but quite a few versions too low for 
Evolution to install.

So, I went through the ./configure and as it complained about each thing not 
there, or too low, I upgraded that on the system. (and upgraded those things 
that pieces complained about, and so on and so on :)
I eventually got to the point where Evo .8 configured ok, but failed in the 
executive summary part of things.  This is when I joined the mailing list, and 
found the fix for it by replacing a couple of files in executive summary.
while I was at it, I grabbed a complete CVS tree of evolution. (being the 
simple way to get what I needed)
I tried a configure of that, and found all I needed was a new GAL, so I 
grabbed that and installed it. But, no joy compiling the CVS tree either.

Soooo, what I have is two trees, neither of which will compile. (and a Gnome 
install so Mucked up I don't think any of the Gnome Apps from Suse have a 
chance of running.  :)

Here's what comes out of the CVS tree compile....
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DG_LOG_DOMAIN=\"calendar-gui\"
-I../../shell                                   -I../../shell                 
-I../..-I../../calendar                         -I../../libical/src/libical   
-I../../libical/src/libical                     -I../../widgets               
-I../../executive-summary                       -I/opt/gnome/include          
-I/opt/gnome/include -DNEED_GNOMESUPPORT_H
-I/opt/gnome/lib/gnome-libs/include -I/usr/lib/glib/include
-I/usr/X11R6/include -I/opt/gnome/include/gnome-xml -I/usr/include
-I/usr/include/gnome-xml -I/opt/gnome/lib/vfs/include -D_REENTRANT
-I/opt/gnome/include -I/usr/include/gnome-xml -I/usr/lib/glib/include
-DNEED_GNOMESUPPORT_H -I/opt/gnome/lib/gnome-libs/include
-I/usr/X11R6/include -I/opt/gnome/include/gnome-xml
-I/opt/gnome/include -DUNICODE_USE_SYSTEM_ICONV                            
-DEVOLUTION_LOCALEDIR=\""/opt/gnome/share/locale"\"  -I/usr/lib/glib/include
-I/usr/X11R6/include  -g -O2 -Wall -Wunused  -c e-calendar-table.c
e-calendar-table.c:396: parse error before E_calendar_table_popup_uiinfo'
e-calendar-table.c:396: warning: type defaults to       nt' in declaration  
of E_calendar_table_popup_uiinfo'
e-calendar-table.c:397: warning: braces around scalar initializer
e-calendar-table.c:397: warning: (near initialization for
e-calendar-table.c:397: GNOME_APP_UI_ITEM' undeclared here (not in a
e-calendar-table.c:397: initializer element is not constant
e-calendar-table.c:397: (near initialization for
e-calendar-table.c:397: warning: implicit declaration of function N_'
e-calendar-table.c:397: warning: excess elements in scalar initializer

And here's what comes out of the .8 compile (with the older but valid GAL, it 
really doesn't like the new one)
This is with replacing just esummary.c and .h, I also tried replacing the 
entire esummary directory as was suggested, but that didn't work either.
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../widgets
-I../../widgets/e-text                                  -I../..
-I../../shell                                           -I../../shell         
-I../../executive-summary/evolution-services            -I/opt/gnome/include
-I/usr/include/gnome-xml -I/usr/lib/glib/include -DNEED_GNOMESUPPORT_H
-I/opt/gnome/lib/gnome-libs/include -I/usr/X11R6/include 
-I/opt/gnome/include/gnome-xml -DUNICODE_USE_SYSTEM_ICONV
-I/usr/lib/glib/include -D_REENTRANT -I/opt/gnome/include
-DUNICODE_USE_SYSTEM_ICONV     -I/opt/gnome/include
-I/opt/gnome/lib/vfs/include -I/usr/lib/glib/include
-D_REENTRANT-I/opt/gnome/include -DUNICODE_USE_SYSTEM_ICONV                   
-I/opt/gnome/include -I/usr/lib/glib/include -DNEED_GNOMESUPPORT_H
-I/opt/gnome/lib/gnome-libs/include -I/usr/X11R6/include
-I/opt/gnome/include/gnome-xml -DUNICODE_USE_SYSTEM_ICONV
-DG_LOG_DOMAIN=\"evolution-executive-summary\"  -I/usr/lib/glib/include
-I/usr/X11R6/include  -g -O2 -Wall -Wunused  -c e-summary.c
e-summary.c: In function E_summary_rebuild_page':
e-summary.c:490: structure has no member named Columns'
e-summary.c:496: structure has no member named Columns'
e-summary.c:458: warning: Columns' might be used uninitialized in this
make[3]: *** [e-summary.o] Error 1
make[3]: Leaving directory

The question is, what should I do?  Which version should I try to get running 
and how do I make my gnome setup at least something like one of these would 
like?  (grabbing Ximian's Gnome would be nice, but they don't seem to make for 
Sparc Linux.  :)

Here's what's installed in the system now. (what was grabbed anyway)
drwxr-xr-x  11 gkm      users        4096 Feb  1 02:42 GConf-0.12
drwxr-xr-x   7 gkm      users        4096 Feb  1 12:09 ORBit-0.5.7
drwxr-xr-x  16 gkm      users        4096 Feb  1 12:37 bonobo-0.33
drwxr-xr-x  27 gkm      users        4096 Feb  1 15:34 evolution-0.8
drwxr-xr-x  21 gkm      users        4096 Feb  1 11:49 gnome-libs-1.2.11
drwxr-xr-x  11 gkm      users        4096 Feb  1 02:30 gnome-print-0.25 
drwxr-xr-x  14 gkm      users        4096 Feb  1 03:31 gnome-vfs-0.5    
drwxr-xr-x   9 gkm      users        4096 Feb  1 12:50 gtkhtml-0.8.2    
drwxr-xr-x   7 gkm      users        4096 Feb  1 01:34 libunicode-0.4   
drwxr-xr-x   8 gkm      users        4096 Feb  1 02:35 libxml-1.8.11    
drwxr-xr-x  11 gkm      users        4096 Feb  1 02:17 oaf-0.6.0
drwxr-xr-x  10 gkm      users        4096 Feb  1 14:07 gal(from CVS)

Hope this makes some sense..

P.S. I really do want to try Evolution, it's just resisting me. :)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]