Re: [Evolution] gtk-doc

The easiest thing to do when the docs dont build is do 'make -k'.  Sure
it doesn't build the docs if there is an error but they're not really
useful to anyone but the guys writing them right now anyway.

On 20 Apr 2001 04:11:19 +0000, dan hensley att net wrote:

Is compiling with gtk-doc supported yet?  I tried compiling yesterday
the 4/18 snapshot, and got the attached error.

This has been happening for the last few days, but unfortunately
I haven't seen anyone from Ximian respond.  I tried to figure out
what was happening tonight, but I have no clue how the gtk-doc stuff
works.  I tried grabbing the latest from CVS, but that didn't fix it.

What did work was to go into the directory with the problem and
run 'make' a few times in a row.  Eventually it went through without
errors.  Of course, you could also remove 'doc' from SUBDIRS in the
top-level Makefile.


Matthew Vanecek
perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'
For 93 million miles, there is nothing between the sun and my shadow except me.
I'm always getting in the way of something...
(cd .                                           \
  && env CFLAGS="                                                       
-I../../../shell/importer                               -I../../../shell               
-I../../..                                               -I../../..             
-I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include 
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/gnome-xml 
-I/usr/lib/vfs/include -D_REENTRANT                             " LDFLAGS="                            
-rdynamic -L/usr/lib -L/usr/X11R6/lib -lbonobo -ltiff -ljpeg -lpng -loaf 
-lORBitCosNaming -lORBit -lIIOP -lORBitutil -lnsl -lbonobox -lglade-gnome 
-lglade -lxml -lz -lgdk_pixbuf -lgnomecanvaspixbuf -lgnomevfs -lgthread 
-lpthread -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -lXi 
-lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1 -lglib -ldl                         
../../../shell/importer/.libs/libevolution-importer.a            "              
         gtkdoc-scanobj --module=evolution-shell-importer               \
  && gtkdoc-scan --module=evolution-shell-importer 
--source-dir=/home/me2v/redhat/BUILD/evolution-0.10/shell/importer           \
importer.h" )
evolution-shell-importer-scan.c:6:51: evolution/importer/evolution-importer.h: 
No such file or directory
evolution/importer/evolution-importer-client.h: No such file or directory
evolution/importer/evolution-importer-listener.h: No such file or directory
evolution-shell-importer-scan.c:693:14: warning: null character(s) preserved in 
Compilation of scanner failed
make[4]: [evolution-shell-importer.signals] Error 1 (ignored)
cd . && gtkdoc-mktmpl --module=evolution-shell-importer
Can't open ./evolution-shell-importer-decl.txt at /usr/bin/gtkdoc-mktmpl line 
make[4]: *** [tmpl/evolution-importer.sgml] Error 2
make[4]: Leaving directory 
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/me2v/redhat/BUILD/evolution-0.10/doc/devel'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/me2v/redhat/BUILD/evolution-0.10/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/me2v/redhat/BUILD/evolution-0.10'
make: *** [all-recursive-am] Error 2

evolution maillist  -  evolution helixcode com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]