[Evolution-hackers] GNOME 3.5.4 + Evolution-EWS JHbuild instant crash


I'm new to building unstable GNOME and Evolution using jhbuild, but I followed the instructions and the compilation went all the way without problems. I want to test and possibly hack on evolution with the EWS plugin.

So, I downloaded all *.modules files from here:


into jhbuild/modulesets/ directory. Since "evolution-ews" wasn't among any of the standard 3.5.4 modules, I edited "gnome-apps-3.5.4.modules" and added the following section to get it included:

  <autotools id="evolution-ews">
    <branch hash="sha256:e4a37fb9b0f36baf0b79dcc9f0770d99d018ee7e169025cb36dc22624dc0c1fb" module="evolution-ews/3.5/evolution-ews-3.5.4.tar.xz" repo="http://download.gnome.org/sources/" size="448032" version="3.5.4"/>
      <dep package="glib"/>
      <dep package="gtk+"/>
      <dep package="libsoup"/>
      <dep package="intltool"/>
      <dep package="evolution-data-server"/>
      <dep package="evolution"/>
      <dep package="sqlite3"/>
      <dep package="libical"/>

I took the <dependencies> list from "gnome-world-3.6.modules" supplied with jhbuild, and I manually added and filled in the <branch/> tag, using the values from the evolution-ews 3.5.4 release files:


Namely, I used the sha256sum from inside:


then set the "size" and "module" to the actual name and size of the release tarball:


and kept "repo" attribute value of "http://download.gnome.org/sources/" as seemed appropriate.

After jhbuild sanitycheck + bootstrap, I rad "jhbuild build", because my ~/.jhbuildrc already lists only "evolution-ews" as the primary module:

use_local_modulesets = True
moduleset = 'gnome-apps-3.5.4'
modules = [ 'evolution-ews' ]

tarballdir = os.path.join(os.environ['HOME'], 'releases', 'checkoutroot')
checkoutroot = os.path.join(os.environ['HOME'], 'releases', moduleset)
prefix = os.path.join(checkoutroot, 'install')
autogenargs='--disable-static --disable-gtk-doc'
tarballdir = os.path.join(checkoutroot, 'pkgs')
skip = [ 'gudev', 'gnome-disk-utility', 'libvirt', 'libvirt-glib', 'gnome-boxes', 'gnome-color-manager']
module_autogenargs['PackageKit'] = autogenargs + ' --disable-systemd'

After successful compilation of all prerequisite modules and evolution-ews, I tried "jhbuild run evolution". A "preview release" window opened, I clicked [OK], and immediately got:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(evolution:16535): e-data-server-WARNING **: (e-source-registry.c:1008):source_registry_initable_init: runtime check failed: (g_hash_table_size (registry->priv->sources) > 0)
camel:ERROR:camel-provider.c:238:camel_provider_register: assertion failed: (provider_table)
Aborted (core dumped)

When I run "evolution-settings" under jhbuild shell, a settings window opens with a "New Account" button, but as soon as I click on it, I get:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(evolution-settings:16905): e-utils-WARNING **: (e-config.c:455):ec_assistant_find_page: runtime check failed: (ii < n_pages)
Segmentation fault (core dumped)

Since everything went fine, the whole compilation was successful, I presume this is somehow my fault. Am I missing some daemon/process/initialization required for the Evolution application to work? I have a vague idea how complex and interconnected GNOME is, so it would only make sense that some "ecosystem" setup would be required first. Can somebody help?

Thank you,
David Kubicek

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]