[Evolution-hackers] Build failure in evo: need a lot of stuff!

Hi all;

I'm getting a build failure in Evo and gtkhtml with the latest glib:
editor-control-factory.c: In function 'editor_get_prop':
editor-control-factory.c:463: error: expected _expression_ before 'do'
Apparently, the latest glib broke the libbonobo from Gnome 2.20, so if you install the latest glib you also need the latest libbonobo.

Do the changes that were recently committed for Evo, etc. to support the new libsoup 2.4 REQUIRE that version?  Will those changes still work with the older version?

If the current SVN head requires libsoup 2.4, which requires a new glib, then we should update configure.in on the Evo components that use libsoup to also require a new-enough libbonobo.  I just did an SVN checkout and the current HEAD version is 2.20.4; I don't know if any 2.20 version is good enough or what.

Hope this helps someone else!  I'll update my makefile with the appropriate info once I get things working again.

 Paul D. Smith <psmith gnu org>                 http://make.mad-scientist.us
 "Please remain calm--I may be mad, but I am a professional."--Mad Scientist

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]