[Evolution-hackers] libeshell.so not installed for evolution's "make install"

Hello, all,

I'm guessing this is the correct mailing list for this question; if not,
please point me to the correct list.

I just tried compiling and installing Evolution from its trunk using the
instructions provided here:


This involved checking out libsoup, gtkhtml, evolution-data-server, and
evolution from the Subversion repositories, then building each component
with the following general steps:

   sudo make install

Everything worked fine until I tried to run "sudo make install" for
evolution itself. It looks like libeshell.so was not installed
to /opt/evo/lib/evolution2.12, causing a link error when
libevolution-test.so is built.

        Making install in shell
        make[1]: Entering directory
        make  install-am
        make[2]: Entering directory
        make[3]: Entering directory
        /bin/bash ../mkinstalldirs /opt/evo/bin
        /bin/bash ../libtool --mode=install /usr/bin/install -c
        evolution /opt/evo/bin/evolution
        libtool: install: warning: `libeshell.la' has not been installed
        in `/opt/evo/lib/evolution/2.12'
        /usr/bin/install -c .libs/evolution /opt/evo/bin/evolution
        test -z "/opt/evo/lib/evolution/2.12/components" || mkdir -p --
         /bin/bash ../libtool --mode=install /usr/bin/install -c
        libtool: install: warning: relinking `libevolution-test.la'
        (cd /home/user/svn/gnome/evolution/shell; /bin/bash ../libtool
        --tag=CC --mode=relink gcc -g -O2 -Wall -Wmissing-prototypes
        -Wno-sign-compare -o libevolution-test.la
        -rpath /opt/evo/lib/evolution/2.12/components -avoid-version
        -module Evolution-common.lo Evolution-skels.lo
        Evolution-stubs.lo evolution-test-component.lo libeshell.la
        -Wl,--export-dynamic -pthread -lgnomeui-2 -lSM -lICE
        -lgnomevfs-2 -lgnome-keyring -lgconf-2 -lbonoboui-2
        -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0
        -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm
        -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi
        -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lbonobo-2
        -lbonobo-activation -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0
        -lrt -lgobject-2.0 -lglib-2.0 )
        -shared  .libs/Evolution-common.o .libs/Evolution-skels.o .libs/Evolution-stubs.o .libs/evolution-test-component.o  -Wl,--rpath -Wl,/opt/evo/lib/evolution/2.12 -L/opt/evo/lib/evolution/2.12 -leshell -L/usr/lib -lgnomeui-2 -lSM -lICE -lgnomevfs-2 -lgnome-keyring -lgconf-2 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lbonobo-2 -lbonobo-activation -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0  -Wl,--export-dynamic -pthread -Wl,-soname -Wl,libevolution-test.so -o .libs/libevolution-test.so
        /usr/bin/ld: cannot find -leshell
        collect2: ld returned 1 exit status
        libtool: install: error: relink `libevolution-test.la' with the
        above command before installing it
        make[3]: *** [install-componentLTLIBRARIES] Error 1
        make[3]: Leaving directory
        make[2]: *** [install-am] Error 2
        make[2]: Leaving directory
        make[1]: *** [install] Error 2
        make[1]: Leaving directory
        make: *** [install-recursive] Error 1

I was able to work around this by installing the missing .so file
manually, then continuing:

        cd shell
        sudo install .libs/libeshell.so /opt/evo/lib/evolution/2.12
        cd ..
        sudo make install

This let me get past the problem, but I wonder if there's a problem with
the Makefile (generated from Makefile.am, if I understand correctly). Is
there some way to confirm that this is the problem? If so, how am I
supposed to report it to the correct group?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]