Re: [Evolution-hackers] Proposed fix for bug 311512



I'm not sure I'd call it get_filter_thread() because it's not getting a
thread, all it is really doing is getting you a 'wait' id (and ugh, the
new session_thread_wait() just busy-waits?)

I think if this type of solution is really the "best" way of doing it,
then I think it'd be better to just have a CamelFolder function
(camel_folder_wait_filtering()? I dunno)that waits for the filtering
operation to finish rather than providing a higher level with a wait id
that it should never have to know or care about.


But better still would be to trap the "folder_changed" signal for
folders that are currently in the process of filtering (CamelFolder
already listens for this event in order to invoke the filtering iirc, so
just stop the signal from propagating) and re-emit it later when
filtering is complete (obviously with the updated changes).

That would be a much cleaner way of doing it.

Jeff


On Wed, 2007-04-25 at 08:13 +0100, Karl Relton wrote:
> Hi friends,
> 
> Could anyone take a look at my proposed patches
> for fixing bug 311512. Srini has had a look, and noted the ABI breakage
> (see below). This was deliberate on my part - the only way to get
> newmail notification to take note of the results of a filter thread.
> 
> Many thanks
> Karl
> 
> On Fri, 2007-03-30 at 12:43 +0530, Srinivasa Ragavan wrote:
> > On Fri, 2007-03-30 at 07:51 +0100, Karl Relton wrote:
> > > Last week I posted two patches (one for eds, one for evo) on evo bugzill
> > > that I believe fix bug 311512.
> > 
> > > --- camel-folder.h.110	2007-03-20 16:57:40.000000000 +0000
> > > +++ camel-folder.h	2007-03-20 16:50:34.000000000 +0000
> > > @@ -195,6 +195,7 @@ typedef struct {
> > >  	void     (*freeze)    (CamelFolder *folder);
> > >  	void     (*thaw)      (CamelFolder *folder);
> > >  	gboolean (*is_frozen) (CamelFolder *folder);
> > > +	int      (*get_filter_thread) (CamelFolder *folder);
> > >  } CamelFolderClass;
> > 
> > On first look, I noticed that your patch has introduced an ABI break in
> > CamelFolderClass. 
> > 
> > I'm sure that the mailer hackers would have a more closer look at it. 
> > 
> > Thanks for your friendly poke :-) 
> > 
> > -Srini.
> > 
> > > f
> > > Could you take a look - any comments are welcome!
> > > 
> 
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]