Re: [Evolution-hackers] Problem Building GtkHtml 3.1.4

On Mër , 2003-12-10 at 11:32, Luis Villa wrote:
> On Wed, 2003-12-10 at 11:11, Rodney Dawes wrote:
> > What version of XML-Parser do you have? I have a feeling that you have
> > an old version that doesn't have the Styles support that newer versions
> > do. OrigTree is a Style module for XML-Parser that comes with intltool.
> > If your XML-Parser doesn't have Style modules support, this would
> > definitely be an issue. I have a feeling that intltool needs to check
> > the version of XML-Parser better, and install the in a
> > better location more suited to XML-Parser.
> Rodney, what version of intltool are you using to generate the evo
> tarballs? IIRC, 0.27.1 is incompatible with 0.28, which is what James is
> using. See the 'New components and intltool' thread on d-d-l for more
> details.

If it's a disted tarball, it doesn't matter because everything is in the
tarball anyway. The issue with disted tarballs and 0.28 is that intltool
isn't including it's or XML-Parser 2.34 when one makes dist.
Building from CVS, the disting isn't an issue, since you need intltool
and XML-Parser 2.34 installed anyway. If you have an older version of
the XML-Parser stuff though, and intltool 0.28, you will get all the
errors about OrigTree and stuff, or if you are building from a tarball
that is disted with 0.28.

I don't know specifically what versions of intltool were used to dist
the Evolution 1.5 tarballs, but we should be doing it with 0.27.2. At
least, that is what the in gal/gtkhtml requires, iirc, and
0.28 is broken.

-- dobey

> Luis
> > On Mër , 2003-12-10 at 05:54, James Ogley wrote:
> > > Hi,
> > > 
> > > I'm trying to build GtkHtml 3.14 for Evo 1.5, but it's failing on
> > > intltool-merge because the OrigTree module isn't installed.
> > > 
> > > I can't find this module in CPAN, and from what I can make out from
> > > Google, it should be included in intltool itself.  I've got intltool
> > > 0.28 installed, which is greater than the version that configure checks
> > > for (0.27.1 or greater).
> > > 
> > > Can I get this module separately?

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]