Re: [Ekiga-list] Push to talk service


We have used  STUN for NAT.
Here we got this in the log: 

06-04 07:12:36.591: D/ register()
06-04 07:12:36.621: D/ realm='', impu='sip:santanu1234 ekiga net', 
06-04 07:12:36.763: D/ STUN=yes
06-04 07:12:36.801: D/ STUN2 - and port=3478
06-04 07:12:36.811: D/ pcscf-host='', pcscf-port='5060', transport='udp', 
06-04 07:12:37.271: D/dalvikvm(1552): GC_CONCURRENT freed 149K, 10% free 2805K/3092K, paused 77ms+110ms, total 267ms
06-0407:12:37.301: D/ ::1%1
06-04 07:12:37.321: D/
06-04 07:12:37.321: D/ fe80::5054:ff:fe12:3456%eth0
06-04 07:12:37.361: D/
06-04 07:12:37.371: D/ Local IP=''
06-04 07:12:37.391: D/ acquireNetworkLock()
06-04 07:12:37.521: D/ netType=0 and netSubType=3
06-04 07:12:37.591: D/ Stack started
06-04 07:12:37.771: D/ OnDialogEvent (Dialog connecting,1)
06-04 07:12:37.841: D/libEGL(1552): loaded /system/lib/egl/
06-04 07:12:37.990: D/(1552): HostConnection::get() New Host Connection established 0x2a174c68, tid 1552
06-04 07:12:38.062: D/libEGL(1552): loaded /system/lib/egl/
06-04 07:12:38.091: D/libEGL(1552): loaded /system/lib/egl/
06-04 07:12:38.192: D/ OnDialogEvent ((un)REGISTER request successfully sent.,1)
06-04 07:12:38.461: W/EGL_emulation(1552): eglSurfaceAttrib not implemented
06-04 07:12:38.481: D/OpenGLRenderer(1552): Enabling debug mode 0
06-04 07:12:43.257: D/dalvikvm(1552): threadid=1: still suspended after undo (sc=1 dc=1)
06-04 07:12:49.641: I/tryingtoregister(1552): Trying to Register...
06-04 07:13:10.241: D/ OnDialogEvent (Transport error.,1)
06-04 07:13:10.271: D/ OnDialogEvent (Dialog terminated,1)
06-04 07:13:10.331: D/ Stack stopped

I have query regarding this:
This time we have used STUN. We are using NGN stack for this implementation. In NGN default STUN is and port=3478. We have also tried using as STUN. but the result is same. Should we use different STUN server and port for ekiga. Please let us know. We are getting transport error in our end and after that stack is stopped. We have tried both UDP and TCP for transport. Please let us know if we are making any wrong for STUN or transport

Kind Regards

On Mon, Jun 3, 2013 at 6:44 PM, Eugen Dedu <Eugen Dedu pu-pm univ-fcomte fr> wrote:
There is not enough information, the only solution would be to see with wireshark what packets are exchanged...

Check also that your client uses STUN, otherwise registering to will not work.

On 03/06/13 12:18, Arijit Chakraborty wrote:

We are trying to register from the mobile client  and getting the following
log :
06-03 11:36:08.053:
D/ History loaded
06-03 11:36:08.123: I/System.out(13214): ==isStarted ====true
06-03 11:36:08.123: D/
06-03 11:36:08.123: D/
impu='sip:santanu123 ekiga net', impi='santanu123'
06-03 11:36:08.143: D/
06-03 11:36:08.143: D/
pcscf-port='5060', transport='udp', ipversion='ipv4'
06-03 11:36:08.173:
D/ ::1%1
06-03 11:36:08.183:
06-03 11:36:08.183:
06-03 11:36:08.183: D/
06-03 11:36:08.183:
06-03 11:36:08.183:
06-03 11:36:08.183: D/
Local IP=''
06-03 11:36:08.183:
06-03 11:36:08.183:
D/ netType=1 and
06-03 11:36:08.213: D/
Stack started
06-03 11:36:08.213: D/
OnDialogEvent (Dialog
06-03 11:36:08.223: D/
OnDialogEvent ((un)REGISTER
request successfully sent.,1)
06-03 11:36:08.233: I/tryingtoregister(13214): Trying to Register...
06-03 11:36:08.253: D/libEGL(13214): loaded
06-03 11:36:08.253: D/libEGL(13214): loaded
06-03 11:36:08.263: D/libEGL(13214): loaded
06-03 11:36:08.263: D/libEGL(13214): loaded

In the Client end we are getting that it is trying to register. But we are
suppose to get a response from the SIP server regarding the status of the
Please have a look in this matter and reply us accordingly so that we can
fix this problem.

Kind Regards

On Fri, May 31, 2013 at 5:36 PM, Eugen Dedu <Eugen Dedu pu-pm univ-fcomte fr

To discover why your client fails to register to, we need to
see the packets exchanged during registration.  Can you send them to us?

On 31/05/13 13:23, Arijit Chakraborty wrote:


We are working on One-to-One Voice communication(half duplex) i.e. Push to
talk over cellular(PoC).

We are using a SIP client which is available in Android  SDK.I have
a SIP account in Ekiga.

I tried to register from my mobile SIP client using the already created
address. But I recieve an error message "No Host to Route".

Can you please let me know that why my client fails to register with your
SIP server, what we understand its a free SIP server which you provide

Kind Regards

On Thu, May 30, 2013 at 7:59 PM, Alex Theotokatos <alex theoto gmail com

  Push to talk service?
Do you mean that you want to use it as cb or you have a problem with
your sound card (non-duplex)?
Have you think about install a switch on your microphone?

On Thu, 2013-05-30 at 19:18 +0530, Arijit Chakraborty wrote:


I have received an SIP address from Ekiga. Can I use it for push to
talk service ?

Kind Regards
ekiga-list mailing list
ekiga-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]