[Ekiga-list] ekiga on Slackware 12.2 not working usefully... any suggestions?


I have recently tried
	ekiga 3.0.1 + opal 3.4.3 + ptlib 2.4.3
	ekiga 3.0.2 + opal 3.4.4 + ptlib 2.4.4
	ekiga 3.1.0 + opal 3.6.0 + ptlib 2.6.0
under Slackware 12.2 (various computers, various kernels).

3.1.0 doesn't let me use my Logitech QuickCam Pro for Notebooks
(uvcvideo, needs V4L2 to work at all on my systems), so I gave up on

The other two versions seem to behave similarly with respect to these

(1) The call recipient sees only his own video, the video of the caller
    is never visible.

(2) If the caller is viewing his own video before making a call, when
    the call is established, he (apparently) alternately sees his own
    video frames and frames of the call recipient.  In other words,
    the video picture is pretty much useless.
    If the two video resolutions are not the same, the (whole) window
    changes size with (apparently) each frame change, which adds to
    the annoyance.

    If the caller was not looking at his own video, he sees the call
    recipient's video fine.

This behaviour happens regardless of which way the call goes.

Neither the caller nor the recipient is able to change anything with
the "View" menu items "Local Video", "Remote Video", "P-in-P" or
"P-in-P in Separate Window".

This is seen when both computers are on the same LAN, so I don't think
there should be any issues with gateways/firewalls/...  I am calling
with addresses like "h323:"

This behaviour is also seen with other web cams, so I don't think the 
particular web cam(s) are relevant.

This is pretty much a show stopper, so the fact that many people are
happily using ekiga suggest to me that it must be "me", but I have no
idea what I'm doing wrong.  Older versions of ekiga worked fine for me
on older versions of Slackware.

Note that Slackware does not have gnome, so (following the SlackBuild
at www.slackbuilds.org) I disable gnome and gconf support (which,
as an aside, I consider to be a large improvement, since gconf has
given me nothing but grief in the past).

FYI, config.log records the following:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --mandir=/u
sr/man --disable-gnome --disable-gconf --disable-avahi --disable-gdu --disable-e
ds --disable-static --build=i486-slackware-linux

Any suggestions?  I'm pretty much dead in the water here.  I would be
happy to try out any patches anyone can provide (3.0.2 and friends
would probably be the best choice, given 3.1.0's recalcitrance).



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]