Re: [Ekiga-list] Ekiga can't receive calls after some time.

limousin ntic fr wrote:


An update to my report :

After the problem has occured, ekiga won't quit properly using the quit menu and the systray icon is frozen until the process is killed.

I tried compiling from source : the last stable tarballs went without problem (PTLIB 2.6.1, OPAL 3.6.1, Ekiga 3.2.0) ; I got a gcc internal error with the latest svn/git and couldn't try it.

I confirm that the "can't receive calls after 50 minutes" problem is the same as with the binary packages.

I noticed a strange behaviour in the network traffic dump between Ekiga and the registrars :

- Every 10 seconds, Ekiga sends a few CRLF UDP frames to every SIP registrar. At the bebinning of the session it sends 3 frames to and 2 frames to the other registrar ; after 49 minutes, just before the bug, it sends more than 200 frames every 10 seconds to ! (and still only 2 frames to the other registrar).

- There are several SUBSCRIBE and NOTIFY exchanges with After "The bug", the server keeps sending NOTIFY requests but gets no answer from Ekiga.

- The other registrar sends a "OPTIONS" request every 60 seconds, that is answered by ekiga. After "the bug", the server sends a request per second but gets no answer from Ekiga.

I would be glad if someone could reproduce this behaviour.

The most similar time related issue I could find is Bug 558524, however UI is not completely locked up.

François Lacombe

<limousin ntic fr> a écrit le Fri, 17 Apr 2009 18:55:05



I've been browsing the ekiga website, support sites and the mailing list archive for quite some time but still haven't found anyone having the same problem that I have with Ekiga.

After a certain time online making and receiving calls or idleing, Ekiga can't receive calls until it is restarted. It can still make calls normally though. This time is always the same (see below).

I'm using both Ubuntu and Mandriva and I managed tu reproduce this on every version combination that I tried (using binary packages only) :

ekiga 2.0.12 (ubuntu intrepid ibex), (Mandriva 2009.0)

ekiga 3.0.0 (Mandriva 2009.0 backport)

ekiga 3.0.1 (ubuntu intrepid ibex backport)

ekiga 3.2.0 (ubuntu janty fresh RC1)

I tested it both from home (ADSL, nat with isp router) and work (fiber, nat with professionnal router).

I tried three sip accounts : one from, one from my isp ( and the other from a business voip provider.

During my tests, I tried activating and deactivating stun, using the proxy of the business provider, changing the ip_conntrack_udp_timeout

kernel setting, and changing the delay setting in the Edit Account.

Only the latest does change something :

the time between ekiga startup and the problem occurs is almost the value in this delay setting. 50 minutes (~2980s) is the maximum value after which the delay setting has no effect : it stops after 50 minutes.

I recorded a complete tcpdump of the session with a 3600s delay and two activated accounts in Ekiga 3.0.1 with libopal-2.2.11. After 2980s of activity, Ekiga stops sending CRLF to the server and does not respond to NOTIFY and OPTION requests. I can mp it with debug output if requested.

I am almost certain that it is an ekiga-related problem since Twinke and x-lite on windows works out of the box. However, I need ekiga features like video and multiple sip accounts on linux !

Thanks by advance for your suggestions.

Please open a bug report on bugzilla. It should be useful to include a -d 4 output. If possible, use latest svn/git (it compiles now).

Eugen Dedu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]