Re: [Ekiga-list] 'Video: No Device Found' [2.0.12]

On Thu, 31 Jul 2008 08:14:30 +0200
Fabrice ALPHONSO <fabrice alphonso dyndns org> wrote

Le jeudi 31 juillet 2008 ? 15:05 +1200, Adam Bogacki a ?crit :
> Hi, I have been using Ekiga 2.0.12 on an Etch/unstable system -
> previously recognising both audio & video devices.
> I recently saw reference to trying out snapshots  ..
> Carrying out the instructions at I had
> look at it but decided it was
> a bit too buggy to use at the moment, so apt-removed
'ekiga-snapshot' ..
> but now find that
> Ekiga 2.0.12 does not recognise video devices (Logitech Quickcam
> or 'Go' models) .
> Any ideas for a fix ?

I imagine that for installing ekiga-snapshot you also had to install
ptlib and opal related packages. Are you sure that when you
ekiga-snapshot you also cleaned everything related to ptlib and opal
reinstalled the correct version for those dependencies of ekiga
2.0.12 ?
Yep. I've gone to great lengths to check that I have the right versions of
ptlib and opal (to the extent of reinstalling them).

However, when I run xawtv I get

adam Tohunga:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.24-1-686)
xinerama 0: 1280x1024+0+0
can't open /dev/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such file or directory
v4l2: open /dev/video0: No such file or directory
v4l: open /dev/video0: No such file or directory
no video grabber device available
adam Tohunga:~$
It was previously working with v4l and
Ekiga Preferences now tells me "No device found" ..

I have tried 'mknod /dev/video0 c 81' to no result .. I seem to be missing an operand after '81' ..

I have also created /etc/udev/rules.d/06-dvb.rules and added the following lines:

KERNEL="dvb*", PROGRAM="/etc/udev/scripts/ %k", NAME="%c"
SYSFS{vendor}="0x109e", PROGRAM="/etc/udev/scripts/ %k", NAME="video0"

.. and

edited /etc/udev/scripts/ so thatk it has the following

/bin/echo $1 | /bin/sed -e 's,dvb\([0-9]\)\.\([^0-9]*\)\([0-9]\),dvb/adapter\1/\2\3,'

.. but Etch/Lenny tells me at login that they cannot be applied.

So /dev/video0 still wan't created by udev.

/var/log/messages gives me ..

Aug 3 20:12:59 Tohunga kernel: ip_tables: (C) 2000-2006 Netfilter Core Team Aug 3 20:12:59 Tohunga kernel: nf_conntrack version 0.5.0 (6144 buckets, 24576 max) Aug 3 20:13:23 Tohunga kernel: eth0: Setting full-duplex based on MII#1 link partner capability of 45e1.
Aug  3 21:16:41 Tohunga kernel: Linux video capture interface: v2.00
Searching by 'udev' I get

Jul 13 19:09:41 Tohunga kernel: [    9.620898] udevd version 124 started

.. and

Tohunga:~# ls -la /dev/video
ls: cannot access /dev/video: No such file or directory

What am I missing ?

Adam Bogacki,
afb paradise net nz

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]