[Ekiga-devel-list] [Ekiga-list] 100% cpu?

Hi. (sorry for cross-post, I didn't know which list was the one to post this question to -- devel or users).

I've got ekiga 2.0.12.

Whenever I run it, it ends up taking up 95-99% of the CPU and not working. Sometimes it hangs when trying to connect to my sip account. Sometimes it hangs when trying to make a call. Sometimes it gets partway through a call before hanging. When it hangs in the middle of a call, I suddenly stop receiving audio.

However, even when it's at 99% cpu, it doesn't seem to become unresponsive. I can click the buttons and enter things into the address bar. I can open up the preferences screen or the account screen. I can quit it just fine. It just won't make calls or connect.

What should I be looking at for more info, or what can I do about this?

I tried to compile it with profiling to see what function it's stalling in, but I don't seem to know how to do that. I used this configure command:

./configure --prefix=/opt/ekiga CFLAGS="-g -pg"

However, when I run ekiga, no "gmon.out" file is produced. So if that's going to be the thing I need, then I'll need some help generating it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]