Fwd: little problem

resending without strace output... build is successful but the binary fails...

---------- Forwarded message ----------
From: George Georgalis <george galis org>
Date: Wed, Sep 10, 2014 at 9:30 AM
Subject: Re: little problem
To: discussions about usage and development of dia <dia-list gnome org>

reply inline..

On Tue, Sep 9, 2014 at 1:42 PM, Hans Breuer <hans breuer org> wrote:
Am 09.09.2014 um 22:02 schrieb George Georgalis:

If a developer could send me a patch or point me to the obvious, I'd be
happy to build my own binary?


Thanks, couldn't be easier than that!

However, I have some issues with the build, I'm on Ubuntu 14.04.1 LTS trusty, and it seems I got the deps worked out, but in the end my binary fails. Attached is my build script and below is my dependency resolutions... probably installed more packages than I needed...

<<<<<<<<<<<<<<<<<<< error
In ./configure when intltool is not installed it says: "Your intltool is too old."
>>>>>>> install

<<<<<<<<<<<<<<<<<<< error
No package 'gmodule-2.0' found
No package 'gobject-2.0' found
>>>>>>> install

<<<<<<<<<<<<<<<<<<< error
No package 'gtk+-1.0' found
No package 'libxml-2.0' found
No package 'gdk-pixbuf-2.0' found
>>>>>>> install

<<<<<<<<<<<<<<<<<<< error
/bin/bash ../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../.. -I./../../lib -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/
gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz -I/usr/include/libxml2    -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12      -I/usr/include/libxml2 -I/usr/include/freetype2 -g -O2  -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -MT diapsft2renderer.lo -MD -MP -MF .deps/diapsft2renderer.Tpo -c -o diapsft2renderer.lo diapsft2renderer.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../.. -I./../../lib -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz -I/usr/include/libxml2 -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/freetype2 -g -O2 -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -MT diapsft2renderer.lo -MD -MP -MF .deps/diapsft2renderer.Tpo -c diapsft2renderer.c  -fPIC -DPIC -o .libs/diapsft2renderer.o
diapsft2renderer.c:32:30: fatal error: freetype/ftglyph.h: No such file or directory
 #include <freetype/ftglyph.h>
compilation terminated.
make[3]: *** [diapsft2renderer.lo] Error 1
make[3]: Leaving directory `/usr/local/src/dia-0.97.2/plug-ins/postscript'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/dia-0.97.2/plug-ins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/dia-0.97.2'
make: *** [all] Error 2
>>>>>>> install

but that didn't get me there.... it would seem freetype has changed its path, so I tried

ln -s /usr/include/freetype2 /usr/include/freetype

that leads to successful build/install however the resulting binary fails...

$ /usr/local/dia-0.97.2/bin/dia
Gtk-Message: Failed to load module "gtk+-2.0 >= 2.6.0 glib-2.0 >= 2.6.0 libxml-2.0 gdk-pixbuf-2.0 gthread-2.0"

(dia:31192): GLib-GObject-WARNING **: attempting to add an interface (DiaInteractiveRendererInterface) to class (DiaGdkRenderer) after class_init

** (dia:31192): CRITICAL **: dia_renderer_set_size: assertion 'irenderer != NULL' failed

** (dia:31192): CRITICAL **: dia_renderer_set_size: assertion 'irenderer != NULL' failed
Segmentation fault (core dumped)

I cannot make any sense of the strace, but it's attached. Any recommendations?


George Georgalis, (415) 894-2710, http://www.galis.org/

George Georgalis, (415) 894-2710, http://www.galis.org/

Attachment: dia-inst.sh
Description: Bourne shell script

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]