Need help - icons for shapes missing

It appears that dia is a fine program and getting better and would suit my requirements just fine ... but after installing, I have problems. I've asked on the Linux Debian-user list with no response. I've looked at the dia discussion list for the past several months and do not see anything about my difficulty. I would really like to start using dia!

Here's my posting to the Debian-user list:


I just installed the "dia" package, dia starts up fine but immediately gives me a warning:

failed to load icon for file
cause=Couldn't recognize the image file format for file '/usr/share/dia/shapes/Flowchart/display.png'

and also tells me there are 49 more messages.

I looked in /usr/share/dia/shapes/Flowchart/ and found a listing of the various shapes, including "display.png" and "display.shape". In other words, both the .png and .shape files are there for all the shapes.

On the screen, the place where you'd normally see a small icon of the shape is a placeholder with a red X in the center. All kinds of them.

Clicking and dragging one of the placeholder X icons to the working screen, the shape/symbol is OK. Just cannot see what the shape is until doing that. So I assume the shape/symbol is OK, just the icon file (.png) cannot be found.

Using Wheezy, up to date, i386 version.

I'm not a newbie to Linux, but not a guru either. Dia looks like a fine program for my needs. Any help or hints on solving the missing icons would be appreciated. Am I missing some packages or files? I've gone thru the list on the Debian package page for dia and all seems OK.

[Not to confuse the issue, but I have another problem with synaptic that popped up a couple weeks ago. In the file window, the "supported" symbols (the Debian swirl) and the little box indicating installed or not are missing in those two columns. I only mention this here in case this problem is related to the missing icons above. Synaptic does not give any error message and works fine otherwise.]


...and I did get one query asking a couple questions, so here are my answers:

Yes, the rest of the 49 (error) messages do point to the various other shape files and all have .png extension.

Tried creating user "guest", then started "dia" from that user. Exactly same results.

I completely uninstalled and then reinstalled "libgdk-pixbuf2.0-0", "libpng12-0", along with "dia", "dia-common", "dia-libs", and "dia-shapes". Before reinstalling, removed /usr/share/dia and the ".dia" configuration directory under the username I'm using. Still no change in either dia or synaptic.

I cannot help but think my synaptic problem is related, so I tried starting synaptic from a konsole window (as root) and it displayed a lot of similar messages, only they were in reference to xpm files. Here's a typical synaptic message:

synaptic:3454): Gtk-WARNING **: Could not load image
'synaptic_mini.xpm': Couldn't recognize the image file format for file

I note that the two lib packages you mentioned are used by a multitude of applications and include some that I know are working satisfactory.

OK, something is messed up, either through my error or from upgrading Wheezy. All suggestions welcome.


And I posted the following link to a screen shot:

to give everyone an idea of what I'm talking about visually.

Since posting the above information, I have reinstalled every dependent file listed for the dia package in Debian Wheezy (testing).

I might add that I am using KDE instead of gnome.

Please!  Any help would be greatly appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]