Re: running dia on mac os x 10.3.9, errors with multiple definitions of symbol

On Tue, 2008-02-19 at 14:47 -0800, John Mendenhall wrote:
I am new to dia.  I have installed dia v0.96.1 on
mac os x 10.3.9 using macports.  It has installed
fine.  When I run dia, I am running it from the
X11 that came with Apple.  I have read this may be
a problem.

When I run dia, I get the following output:

(dia:20636): Pango-WARNING **: Error loading GDEF table 85

(dia:20636): Pango-WARNING **: Error loading GSUB table 85

(dia:20636): Pango-WARNING **: Error loading GPOS table 85

dyld: dia multiple definitions of symbol _calculate_object_edge
/opt/local/lib/dia/ definition of _calculate_object_edge
/opt/local/lib/dia/libdia.dylib(geometry.o) definition of _calculate_object_edge

Trace/BPT trap dia

The loading window is displayed.
Then, after the trap, it goes away.

Please let me know of any pointers anyone may have
with regard to what I have done wrong.

That seems to be my fault, I was moving the function, but never deleted
the original.  Apparently, that just works on Linux and Windows.  I've
fixed it in CVS now.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]